aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-02-25 20:24:52 +0100
committerFelix Fietkau <nbd@nbd.name>2018-02-26 19:13:55 +0100
commit38dc678166c8dbdb1f6bdbfd3f070c92f3fe0e04 (patch)
tree1030dfa2866e5d7423374ba320b40b03f8c08125 /toolchain/gcc
parentfc54256bc8d13cf5f314a41ce03695cb424bbee6 (diff)
downloadupstream-38dc678166c8dbdb1f6bdbfd3f070c92f3fe0e04.tar.gz
upstream-38dc678166c8dbdb1f6bdbfd3f070c92f3fe0e04.tar.bz2
upstream-38dc678166c8dbdb1f6bdbfd3f070c92f3fe0e04.zip
gcc: refresh patches for version 7.3.0
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/patches/7.3.0/870-ppc_no_crtsavres.patch2
-rw-r--r--toolchain/gcc/patches/7.3.0/910-mbsd_multi.patch4
-rw-r--r--toolchain/gcc/patches/7.3.0/920-specs_nonfatal_getenv.patch2
-rw-r--r--toolchain/gcc/patches/7.3.0/940-no-clobber-stamp-bits.patch2
-rw-r--r--toolchain/gcc/patches/7.3.0/950-cpp_file_path_translation.patch2
5 files changed, 6 insertions, 6 deletions
diff --git a/toolchain/gcc/patches/7.3.0/870-ppc_no_crtsavres.patch b/toolchain/gcc/patches/7.3.0/870-ppc_no_crtsavres.patch
index 156468b45e..2daff5800a 100644
--- a/toolchain/gcc/patches/7.3.0/870-ppc_no_crtsavres.patch
+++ b/toolchain/gcc/patches/7.3.0/870-ppc_no_crtsavres.patch
@@ -7,7 +7,7 @@ Date: Mon Mar 5 00:51:01 2012 +0000
SVN-Revision: 30814
--- a/gcc/config/rs6000/rs6000.c
+++ b/gcc/config/rs6000/rs6000.c
-@@ -26936,7 +26936,7 @@ rs6000_savres_strategy (rs6000_stack_t *
+@@ -27001,7 +27001,7 @@ rs6000_savres_strategy (rs6000_stack_t *
/* Define cutoff for using out-of-line functions to save registers. */
if (DEFAULT_ABI == ABI_V4 || TARGET_ELF)
{
diff --git a/toolchain/gcc/patches/7.3.0/910-mbsd_multi.patch b/toolchain/gcc/patches/7.3.0/910-mbsd_multi.patch
index 286cfadae7..dab427d94b 100644
--- a/toolchain/gcc/patches/7.3.0/910-mbsd_multi.patch
+++ b/toolchain/gcc/patches/7.3.0/910-mbsd_multi.patch
@@ -114,7 +114,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
; On SVR4 targets, it also controls whether or not to emit a
--- a/gcc/opts.c
+++ b/gcc/opts.c
-@@ -1928,6 +1928,9 @@ common_handle_option (struct gcc_options
+@@ -1934,6 +1934,9 @@ common_handle_option (struct gcc_options
opts, opts_set, loc, dc);
break;
@@ -126,7 +126,7 @@ Date: Tue Jul 31 00:52:27 2007 +0000
opts->x_warn_larger_than = value != -1;
--- a/gcc/doc/invoke.texi
+++ b/gcc/doc/invoke.texi
-@@ -6567,6 +6567,17 @@ This option is only supported for C and
+@@ -6569,6 +6569,17 @@ This option is only supported for C and
@option{-Wall} and by @option{-Wpedantic}, which can be disabled with
@option{-Wno-pointer-sign}.
diff --git a/toolchain/gcc/patches/7.3.0/920-specs_nonfatal_getenv.patch b/toolchain/gcc/patches/7.3.0/920-specs_nonfatal_getenv.patch
index 69b40621dc..a0fdc5f165 100644
--- a/toolchain/gcc/patches/7.3.0/920-specs_nonfatal_getenv.patch
+++ b/toolchain/gcc/patches/7.3.0/920-specs_nonfatal_getenv.patch
@@ -7,7 +7,7 @@ Date: Sat Apr 21 03:02:39 2012 +0000
--- a/gcc/gcc.c
+++ b/gcc/gcc.c
-@@ -9280,8 +9280,10 @@ getenv_spec_function (int argc, const ch
+@@ -9281,8 +9281,10 @@ getenv_spec_function (int argc, const ch
value = varname;
if (!value)
diff --git a/toolchain/gcc/patches/7.3.0/940-no-clobber-stamp-bits.patch b/toolchain/gcc/patches/7.3.0/940-no-clobber-stamp-bits.patch
index 8b88b4066d..1dec4015e1 100644
--- a/toolchain/gcc/patches/7.3.0/940-no-clobber-stamp-bits.patch
+++ b/toolchain/gcc/patches/7.3.0/940-no-clobber-stamp-bits.patch
@@ -22,7 +22,7 @@ Date: Fri Dec 12 17:01:57 2014 +0000
--- a/libstdc++-v3/include/Makefile.in
+++ b/libstdc++-v3/include/Makefile.in
-@@ -1476,7 +1476,7 @@ stamp-bits: ${bits_headers}
+@@ -1475,7 +1475,7 @@ stamp-bits: ${bits_headers}
@$(STAMP) stamp-bits
stamp-bits-sup: stamp-bits ${bits_sup_headers}
diff --git a/toolchain/gcc/patches/7.3.0/950-cpp_file_path_translation.patch b/toolchain/gcc/patches/7.3.0/950-cpp_file_path_translation.patch
index 60729dd7fe..e1fd55e405 100644
--- a/toolchain/gcc/patches/7.3.0/950-cpp_file_path_translation.patch
+++ b/toolchain/gcc/patches/7.3.0/950-cpp_file_path_translation.patch
@@ -63,7 +63,7 @@ Forward ported from attachment to https://gcc.gnu.org/bugzilla/show_bug.cgi?id=4
When preprocessing, handle directives, but do not expand macros.
--- a/gcc/doc/invoke.texi
+++ b/gcc/doc/invoke.texi
-@@ -11863,6 +11863,12 @@ by @option{-fplugin=@var{name}} instead
+@@ -11865,6 +11865,12 @@ by @option{-fplugin=@var{name}} instead
@option{-fplugin=@var{path}/@var{name}.so}. This option is not meant
to be used by the user, but only passed by the driver.