aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-03-24 18:29:51 -0700
committerHauke Mehrtens <hauke@hauke-m.de>2020-04-13 22:40:19 +0200
commit1647790ae6202bd70b199e2aa44f8eb43e8d3af1 (patch)
treec8a13eb8b2e2ac087890ea31d544f83bdfd26db6 /toolchain/gcc
parentd27623b542548b765ddd46b046169006a3b5f66f (diff)
downloadupstream-1647790ae6202bd70b199e2aa44f8eb43e8d3af1.tar.gz
upstream-1647790ae6202bd70b199e2aa44f8eb43e8d3af1.tar.bz2
upstream-1647790ae6202bd70b199e2aa44f8eb43e8d3af1.zip
toolchain/gcc: remove uclibc hack
This was introduced with 014d3b98b96872d020ffccf0358ba60967b3f1c0 , which is almost 10 years old. uClibc-ng does not suffer from this problem. Note that this hack prevents libstdc++ from using C++11 math functions. Tested by removing all of the mpd patches designed to fix this and compiling. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/common.mk3
1 files changed, 0 insertions, 3 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 5f237e4520..090aa2447d 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -74,9 +74,6 @@ TAR_OPTIONS += \
--exclude=libjava
export libgcc_cv_fixed_point=no
-ifdef CONFIG_USE_UCLIBC
- export glibcxx_cv_c99_math_tr1=no
-endif
ifdef CONFIG_INSTALL_GCCGO
export libgo_cv_c_split_stack_supported=no
endif