aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/patches/4.1.1/300-libstdc++-pic.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-03-28 17:52:00 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-03-28 17:52:00 +0000
commit92f558c4bea9f0dbcae26c34e73b27a1d2edfb4c (patch)
tree61aad63afab7dd49ad416731b75d27d360843c24 /toolchain/gcc/patches/4.1.1/300-libstdc++-pic.patch
parente172d1c9eaa899b96dc0799a3d002b40bea725e4 (diff)
downloadupstream-92f558c4bea9f0dbcae26c34e73b27a1d2edfb4c.tar.gz
upstream-92f558c4bea9f0dbcae26c34e73b27a1d2edfb4c.tar.bz2
upstream-92f558c4bea9f0dbcae26c34e73b27a1d2edfb4c.zip
Nuke lots of obsolete compiler versions Make gcc4 depend on !LINUX_2_4 - I'm getting sick of seeing people complain about compile errors when trying to build brcm-2.4 with it.
SVN-Revision: 6744
Diffstat (limited to 'toolchain/gcc/patches/4.1.1/300-libstdc++-pic.patch')
-rw-r--r--toolchain/gcc/patches/4.1.1/300-libstdc++-pic.patch50
1 files changed, 0 insertions, 50 deletions
diff --git a/toolchain/gcc/patches/4.1.1/300-libstdc++-pic.patch b/toolchain/gcc/patches/4.1.1/300-libstdc++-pic.patch
deleted file mode 100644
index 560bcb237b..0000000000
--- a/toolchain/gcc/patches/4.1.1/300-libstdc++-pic.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-# DP: Build and install libstdc++_pic.a library.
-
---- gcc/libstdc++-v3/src/Makefile.am
-+++ gcc/libstdc++-v3/src/Makefile.am
-@@ -214,6 +214,12 @@
- $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LDFLAGS) -o $@
-
-
-+install-exec-local:
-+ifeq ($(enable_shared),yes)
-+ $(AR) cru libstdc++_pic.a .libs/*.o $(top_builddir)/libsupc++/*.o
-+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir)
-+endif
-+
- # Added bits to build debug library.
- if GLIBCXX_BUILD_DEBUG
- all-local: build_debug
---- gcc/libstdc++-v3/src/Makefile.in
-+++ gcc/libstdc++-v3/src/Makefile.in
-@@ -627,7 +627,7 @@
-
- install-data-am: install-data-local
-
--install-exec-am: install-toolexeclibLTLIBRARIES
-+install-exec-am: install-toolexeclibLTLIBRARIES install-exec-local
-
- install-info: install-info-am
-
-@@ -660,6 +660,7 @@
- distclean-libtool distclean-tags distdir dvi dvi-am html \
- html-am info info-am install install-am install-data \
- install-data-am install-data-local install-exec \
-+ install-exec-local \
- install-exec-am install-info install-info-am install-man \
- install-strip install-toolexeclibLTLIBRARIES installcheck \
- installcheck-am installdirs maintainer-clean \
-@@ -743,6 +743,13 @@
- install_debug:
- (cd ${debugdir} && $(MAKE) \
- toolexeclibdir=$(glibcxx_toolexeclibdir)/debug install)
-+
-+install-exec-local:
-+ifeq ($(enable_shared),yes)
-+ $(AR) cru libstdc++_pic.a *.o $(top_builddir)/libsupc++/*.o
-+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir)
-+endif
-+
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT: