aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/minimal
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-04-03 10:41:07 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-04-03 10:41:07 +0000
commit84d0582ddb863314e513fdb6dbdec7d2b3b89e93 (patch)
tree2e0610786514abdc658fb4c0b04750503bd8d619 /toolchain/gcc/minimal
parent9b3b0473aed09239c5bca27616e0a455432820e6 (diff)
downloadupstream-84d0582ddb863314e513fdb6dbdec7d2b3b89e93.tar.gz
upstream-84d0582ddb863314e513fdb6dbdec7d2b3b89e93.tar.bz2
upstream-84d0582ddb863314e513fdb6dbdec7d2b3b89e93.zip
remove the old (and nonworking) hack and identify our patched GCCs properly
SVN-Revision: 36189
Diffstat (limited to 'toolchain/gcc/minimal')
-rw-r--r--toolchain/gcc/minimal/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/toolchain/gcc/minimal/Makefile b/toolchain/gcc/minimal/Makefile
index ee8291606c..6b4a9c526f 100644
--- a/toolchain/gcc/minimal/Makefile
+++ b/toolchain/gcc/minimal/Makefile
@@ -21,9 +21,8 @@ define Host/Prepare
ln -snf $(GCC_DIR) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
$(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
$(SED) 's,^MULTILIB_OSDIRNAMES,# MULTILIB_OSDIRNAMES,' $(HOST_BUILD_DIR)/gcc/config/*/t-*
- $(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(HOST_BUILD_DIR)/gcc/version.c
- $(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:$(BUGURL)>\2,' $(HOST_BUILD_DIR)/gcc/version.c
- $(SED) 's,http://gcc.gnu.org/bugs.html,$(BUGURL),' $(HOST_BUILD_DIR)/gcc/configure
+ $(SED) 'd' $(HOST_BUILD_DIR)/gcc/DATESTAMP
+ $(SED) 'd' $(HOST_BUILD_DIR)/gcc/DEV-PHASE
#(cd $(HOST_BUILD_DIR)/libstdc++-v3; autoconf;);
$(SED) 's,gcc_no_link=yes,gcc_no_link=no,' $(HOST_BUILD_DIR)/libstdc++-v3/configure
mkdir -p $(GCC_BUILD_DIR)