aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/initial
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2012-06-30 18:12:15 +0000
committerFelix Fietkau <nbd@openwrt.org>2012-06-30 18:12:15 +0000
commite74e4dbd29f86f25da1285c574b8587e1626a585 (patch)
treeea946200c53429938a8be7c3083719cf96a10a4e /toolchain/gcc/initial
parentb2e5c5f82e2c0340649d514bfb3bb6382ae39041 (diff)
downloadupstream-e74e4dbd29f86f25da1285c574b8587e1626a585.tar.gz
upstream-e74e4dbd29f86f25da1285c574b8587e1626a585.tar.bz2
upstream-e74e4dbd29f86f25da1285c574b8587e1626a585.zip
toolchain: keep the initial gcc around for later uclibc rebuilds
testing uclibc changes is tricky because the final gcc tends to miscompile uclibc code or barf up internal compiler errors. install binutils into $(TOOLCHAIN_DIR)/initial (without changing the configure prefix) and copy it from there to $(TOOLCHAIN_DIR)/ so that the initial gcc can be put into $(PATH) for the uclibc build, even if the final gcc is already installed. SVN-Revision: 32553
Diffstat (limited to 'toolchain/gcc/initial')
-rw-r--r--toolchain/gcc/initial/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/toolchain/gcc/initial/Makefile b/toolchain/gcc/initial/Makefile
index f3f78b0b2f..3d8ab61cdf 100644
--- a/toolchain/gcc/initial/Makefile
+++ b/toolchain/gcc/initial/Makefile
@@ -19,14 +19,17 @@ endef
define Host/Install
$(GCC_MAKE) -C $(GCC_BUILD_DIR) \
+ prefix="$(TOOLCHAIN_DIR)/initial" \
install-gcc \
$(if $(GCC_BUILD_TARGET_LIBGCC),install-target-libgcc)
# XXX: glibc insists on linking against libgcc_eh
- ( cd $(TOOLCHAIN_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
+ ( cd $(TOOLCHAIN_DIR)/initial/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
[ -e libgcc_eh.a ] || ln -sf libgcc.a libgcc_eh.a ; \
cp libgcc.a libgcc_initial.a; \
)
+
+ $(CP) $(TOOLCHAIN_DIR)/initial/. $(TOOLCHAIN_DIR)/
endef
$(eval $(call HostBuild))