aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/initial
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-08-19 12:49:51 +0000
commit62c174067616a911ef77a8cf02a6cc2220e534ec (patch)
tree30ea6c074ef3e3c343c672c2fcc492453ed252e2 /toolchain/gcc/initial
parentd9e0d5705ab187ff024067049f1077f95074a6c6 (diff)
downloadupstream-62c174067616a911ef77a8cf02a6cc2220e534ec.tar.gz
upstream-62c174067616a911ef77a8cf02a6cc2220e534ec.tar.bz2
upstream-62c174067616a911ef77a8cf02a6cc2220e534ec.zip
toolchain: fix the sysroot mess by getting rid of $(TOOLCHAIN_DIR)/usr and moving it back to $(TOOLCHAIN_DIR), this change makes the toolchain relocatable again, which should fix the SDK
SVN-Revision: 22723
Diffstat (limited to 'toolchain/gcc/initial')
-rw-r--r--toolchain/gcc/initial/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/gcc/initial/Makefile b/toolchain/gcc/initial/Makefile
index 8cc6b3be14..f3f78b0b2f 100644
--- a/toolchain/gcc/initial/Makefile
+++ b/toolchain/gcc/initial/Makefile
@@ -4,7 +4,7 @@ include ../common.mk
GCC_CONFIGURE += \
--with-newlib \
- --with-sysroot=$(BUILD_DIR_TOOLCHAIN)/$(LIBC)-dev \
+ --with-sysroot=$(TOOLCHAIN_DIR) \
--enable-languages=c \
--disable-shared \
--disable-threads \
@@ -23,7 +23,7 @@ define Host/Install
$(if $(GCC_BUILD_TARGET_LIBGCC),install-target-libgcc)
# XXX: glibc insists on linking against libgcc_eh
- ( cd $(TOOLCHAIN_DIR)/usr/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
+ ( cd $(TOOLCHAIN_DIR)/lib/gcc/$(REAL_GNU_TARGET_NAME)/$(PKG_VERSION) ; \
[ -e libgcc_eh.a ] || ln -sf libgcc.a libgcc_eh.a ; \
cp libgcc.a libgcc_initial.a; \
)