aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/final
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-04-07 10:11:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-04-07 10:11:41 +0000
commitc270db592a9bfc16b950ad1469a9133c8905af12 (patch)
treeaa08fe17dae50c7fb1810dcb309a7a300dd8f56b /toolchain/gcc/final
parent46072644e50fdfa3e996855a1466219fd7b51d3b (diff)
downloadupstream-c270db592a9bfc16b950ad1469a9133c8905af12.tar.gz
upstream-c270db592a9bfc16b950ad1469a9133c8905af12.tar.bz2
upstream-c270db592a9bfc16b950ad1469a9133c8905af12.zip
gcc: remove the bogus CONFIG_TLS_SUPPORT symbol - TLS support is required by libc.
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 36240
Diffstat (limited to 'toolchain/gcc/final')
-rw-r--r--toolchain/gcc/final/Makefile8
1 files changed, 0 insertions, 8 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index e8c32f629d..2c25263db1 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -15,14 +15,6 @@ ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
--with-libelf=$(TOPDIR)/staging_dir/host
endif
-ifneq ($(CONFIG_TLS_SUPPORT),)
- GCC_CONFIGURE += \
- --enable-tls
-else
- GCC_CONFIGURE += \
- --disable-tls
-endif
-
ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
GCC_CONFIGURE += \
--enable-sjlj-exceptions