aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/final
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-05 14:59:45 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-05 14:59:45 +0000
commit749d865aa4e6fa085e9b72cc5cfe11519f2ba3bd (patch)
treef73964caa33312377d2415ce636b8acc1b405ab1 /toolchain/gcc/final
parent063074cf0ced47cfd741681e5ab0fc2ea31f93ed (diff)
downloadupstream-749d865aa4e6fa085e9b72cc5cfe11519f2ba3bd.tar.gz
upstream-749d865aa4e6fa085e9b72cc5cfe11519f2ba3bd.tar.bz2
upstream-749d865aa4e6fa085e9b72cc5cfe11519f2ba3bd.zip
gcc: gcc 4.9.x disable libsanitize
gcc 4.9.x enables building of libsanitize - libsanitize needs some headers that are not available in uclibc (netrom/netrom.h) according to buildroot project: - build fail with musl - need wordexp with uclibc which increases uclibc size http://git.buildroot.net/buildroot/commit/?id=5f4d658d888b539de9a6247ae5b1a0999de5d4ec http://git.buildroot.net/buildroot/commit/?id=554e29e267e6b36a0fd78c82cbad2c82d939eb7f Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> SVN-Revision: 42767
Diffstat (limited to 'toolchain/gcc/final')
-rw-r--r--toolchain/gcc/final/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 3529616fd5..3fb5ccf83f 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -4,6 +4,7 @@ include ../common.mk
GCC_CONFIGURE += \
--with-headers=$(TOOLCHAIN_DIR)/include \
+ --disable-libsanitizer \
--enable-languages=$(TARGET_LANGUAGES) \
--enable-shared \
--enable-threads \