aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/final
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-18 03:15:22 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-18 03:15:22 +0000
commit64dc82eab0b2963698042f250eca44fcb3bba4f0 (patch)
tree7d1742ce0ef3b5b4350b356d17d8cb4c6454c1ec /toolchain/gcc/final
parent6df3af8a3695a3b204d87e2ba032953bce693c56 (diff)
downloadupstream-64dc82eab0b2963698042f250eca44fcb3bba4f0.tar.gz
upstream-64dc82eab0b2963698042f250eca44fcb3bba4f0.tar.bz2
upstream-64dc82eab0b2963698042f250eca44fcb3bba4f0.zip
invoke patch-specs.sh in the gcc/final install stage. Patch up OpenWrts own cross toolchains to always search headers and libraries in $STAGING_DIR, this should solve most issues with missing headers, indirect linking and not found libraries. At a later stage, all -I and -L flags will be purged from TARGET_LDFLAGS and TARGET_CPPFLAGS.
SVN-Revision: 29768
Diffstat (limited to 'toolchain/gcc/final')
-rw-r--r--toolchain/gcc/final/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index dc884ab9c1..dcab9094e2 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -70,6 +70,7 @@ define Host/Install
done; \
);
$(if $(CONFIG_EXTRA_TARGET_ARCH),$(call SetupExtraArch))
+ $(SCRIPT_DIR)/patch-specs.sh "$(TOOLCHAIN_DIR)"
endef
$(eval $(call HostBuild))