aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/final
diff options
context:
space:
mode:
authorMatteo Croce <matteo.croce@canonical.com>2016-07-15 12:17:20 +0200
committerFelix Fietkau <nbd@nbd.name>2016-08-11 10:45:33 +0200
commit360fd10ac9cb92425709c76ded0cd418662e121e (patch)
tree26d6031217d47f44e751db9a98fc797268858481 /toolchain/gcc/final
parent1645abffea2785653de27d92ba0e977d1f32a538 (diff)
downloadupstream-360fd10ac9cb92425709c76ded0cd418662e121e.tar.gz
upstream-360fd10ac9cb92425709c76ded0cd418662e121e.tar.bz2
upstream-360fd10ac9cb92425709c76ded0cd418662e121e.zip
gcc: optionally build gccgo compiler
Tested with eglibc on x86 and armv7 so far Signed-off-by: Matteo Croce <matteo.croce@canonical.com>
Diffstat (limited to 'toolchain/gcc/final')
-rw-r--r--toolchain/gcc/final/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 3434d894a2..01fec38027 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -39,7 +39,16 @@ define Host/Configure
);
endef
+ifeq ($(CONFIG_USE_GLIBC)$(CONFIG_INSTALL_GCCGO),yy)
+define FixGogccCrt
+ # link crtX.o for gotools
+ mkdir -p $(GCC_BUILD_DIR)/gotools
+ $(foreach crt, i 1 n, ln -sf ../../glibc-dev/lib/crt$(crt).o $(GCC_BUILD_DIR)/gotools/ ; )
+endef
+endif
+
define Host/Compile
+ $(FixGogccCrt)
+$(GCC_MAKE) $(HOST_JOBS) -C $(GCC_BUILD_DIR) all
endef