aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/final
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-02-09 13:35:07 +0100
committerFelix Fietkau <nbd@nbd.name>2017-02-09 14:49:34 +0100
commit0f5d17a7e6acceb18867fd951b231bfb6c4d8946 (patch)
tree5d044ca7efc1e33bb32fd3457cb69940ef3c7dca /toolchain/gcc/final
parent43332f513baf35e2bcd3285d7c93d592001943f6 (diff)
downloadupstream-0f5d17a7e6acceb18867fd951b231bfb6c4d8946.tar.gz
upstream-0f5d17a7e6acceb18867fd951b231bfb6c4d8946.tar.bz2
upstream-0f5d17a7e6acceb18867fd951b231bfb6c4d8946.zip
toolchain/gcc: parallelize make install
If the staging dir was deleted, the build needs to recompile some files. This change speeds up this corner case significantly Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/gcc/final')
-rw-r--r--toolchain/gcc/final/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gcc/final/Makefile b/toolchain/gcc/final/Makefile
index 01fec38027..b815f677d6 100644
--- a/toolchain/gcc/final/Makefile
+++ b/toolchain/gcc/final/Makefile
@@ -67,7 +67,7 @@ endef
define Host/Install
$(CleanupToolchain)
- $(_SINGLE)$(GCC_MAKE) -C $(GCC_BUILD_DIR) install
+ +$(GCC_MAKE) $(HOST_JOBS) -C $(GCC_BUILD_DIR) install
# Set up the symlinks to enable lying about target name.
set -e; \
(cd $(TOOLCHAIN_DIR); \