aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorIan Cooper <iancooper@hotmail.com>2020-06-15 22:14:04 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2020-06-17 23:57:07 +0200
commitb933f9cf0cb254e368027cad6d5799e45b237df5 (patch)
tree26bbaa3322a276dac5d7cf456d51c328baac9a7e /toolchain/gcc/common.mk
parentba7ddae9a9d0aae9aaf00cfb2438286c2ee21098 (diff)
downloadupstream-b933f9cf0cb254e368027cad6d5799e45b237df5.tar.gz
upstream-b933f9cf0cb254e368027cad6d5799e45b237df5.tar.bz2
upstream-b933f9cf0cb254e368027cad6d5799e45b237df5.zip
toolchain: remove gcc libssp and use libc variant
Removes the standalone implementation of stack smashing protection in gcc's libssp in favour of the native implementation available in glibc and uclibc. Musl libc already uses its native ssp, so this patch does not affect musl-based toolchains. Stack smashing protection configuration options are now uniform across all supported libc variants. This also makes kernel-level stack smashing protection available for x86_64 and i386 builds using non-musl libc. Signed-off-by: Ian Cooper <iancooper@hotmail.com>
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk9
1 files changed, 1 insertions, 8 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 7fb30285aa..ec3ea8fff1 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -104,6 +104,7 @@ GCC_CONFIGURE:= \
--disable-multilib \
--disable-libmpx \
--disable-nls \
+ --disable-libssp \
$(GRAPHITE_CONFIGURE) \
--with-host-libstdcxx=-lstdc++ \
$(SOFT_FLOAT_CONFIG_OPTION) \
@@ -131,14 +132,6 @@ ifneq ($(CONFIG_GCC_DEFAULT_SSP),)
--enable-default-ssp
endif
-ifneq ($(CONFIG_GCC_LIBSSP),)
- GCC_CONFIGURE+= \
- --enable-libssp
-else
- GCC_CONFIGURE+= \
- --disable-libssp
-endif
-
ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
GCC_CONFIGURE+= \
--enable-biarch \