aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-11-02 14:16:20 +0100
committerFelix Fietkau <nbd@nbd.name>2017-11-02 15:58:45 +0100
commit7e2c271a8053df940d554cc5e17066033da4fc82 (patch)
tree6c0d95b1862bec9e4d4d2f9059cbbec4e6def0a8 /toolchain/gcc/common.mk
parent23dd6db2ea6d783c16bf10b43c23478b7f26723d (diff)
downloadupstream-7e2c271a8053df940d554cc5e17066033da4fc82.tar.gz
upstream-7e2c271a8053df940d554cc5e17066033da4fc82.tar.bz2
upstream-7e2c271a8053df940d554cc5e17066033da4fc82.zip
gcc: remove support for libgcj/java
It has been removed in gcc 7 Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk7
1 files changed, 2 insertions, 5 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index d7e205a011..f22b8adc2a 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -74,14 +74,11 @@ HOST_STAMP_CONFIGURED:=$(GCC_BUILD_DIR)/.configured
HOST_STAMP_INSTALLED:=$(HOST_BUILD_PREFIX)/stamp/.gcc_$(GCC_VARIANT)_installed
SEP:=,
-TARGET_LANGUAGES:="c,c++$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)$(if $(CONFIG_INSTALL_GCCGO),$(SEP)go)"
+TARGET_LANGUAGES:="c,c++$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)$(if $(CONFIG_INSTALL_GCCGO),$(SEP)go)"
TAR_OPTIONS += \
--exclude-from='$(CURDIR)/../exclude-testsuite' --exclude=gcc/ada/*.ad* \
-
-ifndef CONFIG_INSTALL_LIBGCJ
- TAR_OPTIONS += --exclude=libjava
-endif
+ --exclude=libjava
export libgcc_cv_fixed_point=no
ifdef CONFIG_USE_UCLIBC