aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/common.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-05-04 15:18:13 +0200
committerFelix Fietkau <nbd@nbd.name>2017-05-25 19:01:07 +0200
commit70c2c8ff3938d75425d544aac6a7e9966ae6a165 (patch)
tree2b277c86d79e1185990226a6b7d53978430069ab /toolchain/gcc/common.mk
parenta0f4b4b3a2cd4db1a2b9bab3c06970361192368f (diff)
downloadupstream-70c2c8ff3938d75425d544aac6a7e9966ae6a165.tar.gz
upstream-70c2c8ff3938d75425d544aac6a7e9966ae6a165.tar.bz2
upstream-70c2c8ff3938d75425d544aac6a7e9966ae6a165.zip
toolchain: add gcc 7.1.0 support
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/gcc/common.mk')
-rw-r--r--toolchain/gcc/common.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/toolchain/gcc/common.mk b/toolchain/gcc/common.mk
index 47767d53a9..55ae1a2c09 100644
--- a/toolchain/gcc/common.mk
+++ b/toolchain/gcc/common.mk
@@ -36,6 +36,10 @@ ifeq ($(PKG_VERSION),6.3.0)
PKG_HASH:=f06ae7f3f790fbf0f018f6d40e844451e6bc3b7bc96e128e63b09825c1f8b29f
endif
+ifeq ($(PKG_VERSION),7.1.0)
+ PKG_HASH:=8a8136c235f64c6fef69cac0d73a46a1a09bb250776a050aec8f9fc880bebc17
+endif
+
ifneq ($(CONFIG_GCC_VERSION_6_2_ARC),)
PKG_VERSION:=6.2.1
PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/gcc/archive/$(GCC_VERSION)
@@ -71,7 +75,8 @@ HOST_STAMP_INSTALLED:=$(HOST_BUILD_PREFIX)/stamp/.gcc_$(GCC_VARIANT)_installed
SEP:=,
TARGET_LANGUAGES:="c,c++$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)$(if $(CONFIG_INSTALL_GFORTRAN),$(SEP)fortran)$(if $(CONFIG_INSTALL_GCCGO),$(SEP)go)"
-TAR_OPTIONS += --exclude='gcc/testsuite/*' --exclude=gcc/ada/*.ad*
+TAR_OPTIONS += \
+ --exclude-from='$(CURDIR)/../exclude-testsuite' --exclude=gcc/ada/*.ad* \
ifndef CONFIG_INSTALL_LIBGCJ
TAR_OPTIONS += --exclude=libjava