aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/eglibc
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-11-22 12:27:39 +0000
committerNicolas Thill <nico@openwrt.org>2009-11-22 12:27:39 +0000
commitcfad7b6c08e9c428895872599047c39d6cefa064 (patch)
tree722d4475c631c69697685de07ff952403a1e5cf5 /toolchain/eglibc
parent23bbc4f3e06b4db490a9a66eac3e179ca84a8778 (diff)
downloadupstream-cfad7b6c08e9c428895872599047c39d6cefa064.tar.gz
upstream-cfad7b6c08e9c428895872599047c39d6cefa064.tar.bz2
upstream-cfad7b6c08e9c428895872599047c39d6cefa064.zip
eglibc: don't use minor version numbers in config symbols, only in version strings
SVN-Revision: 18474
Diffstat (limited to 'toolchain/eglibc')
-rw-r--r--toolchain/eglibc/Config.in12
-rw-r--r--toolchain/eglibc/Config.version12
-rw-r--r--toolchain/eglibc/Makefile12
3 files changed, 14 insertions, 22 deletions
diff --git a/toolchain/eglibc/Config.in b/toolchain/eglibc/Config.in
index 80f4fdee3e..407240b8c4 100644
--- a/toolchain/eglibc/Config.in
+++ b/toolchain/eglibc/Config.in
@@ -5,8 +5,8 @@ choice
help
Select the version of eglibc you wish to use.
- config EGLIBC_VERSION_2_6_1
- bool "eglibc 2.6.1"
+ config EGLIBC_VERSION_2_6
+ bool "eglibc 2.6"
config EGLIBC_VERSION_2_7
bool "eglibc 2.7"
@@ -17,8 +17,8 @@ choice
config EGLIBC_VERSION_2_9
bool "eglibc 2.9"
- config EGLIBC_VERSION_2_10_1
- bool "eglibc 2.10.1"
+ config EGLIBC_VERSION_2_10
+ bool "eglibc 2.10"
config EGLIBC_VERSION_TRUNK
bool "eglibc trunk"
@@ -29,11 +29,11 @@ config EGLIBC_REVISION
string
prompt "eglibc revision"
depends on TOOLCHAINOPTS && USE_EGLIBC
- default "5887" if EGLIBC_VERSION_2_6_1
+ default "5887" if EGLIBC_VERSION_2_6
default "8588" if EGLIBC_VERSION_2_7
default "8587" if EGLIBC_VERSION_2_8
default "8690" if EGLIBC_VERSION_2_9
- default "8873" if EGLIBC_VERSION_2_10_1
+ default "8873" if EGLIBC_VERSION_2_10
default "HEAD" if EGLIBC_VERSION_TRUNK
default ""
diff --git a/toolchain/eglibc/Config.version b/toolchain/eglibc/Config.version
index 00b3722eae..e312826816 100644
--- a/toolchain/eglibc/Config.version
+++ b/toolchain/eglibc/Config.version
@@ -1,17 +1,9 @@
config EGLIBC_VERSION
string
depends on USE_EGLIBC
- default "2.6.1" if EGLIBC_VERSION_2_6_1
+ default "2.6.1" if EGLIBC_VERSION_2_6
default "2.7" if EGLIBC_VERSION_2_7
default "2.8" if EGLIBC_VERSION_2_8
default "2.9" if EGLIBC_VERSION_2_9
- default "2.10.1" if EGLIBC_VERSION_2_10_1
+ default "2.10.1" if EGLIBC_VERSION_2_10
default "trunk"
-
-config EGLIBC_VERSION_2_6
- bool
- default y if EGLIBC_VERSION_2_6_1
-
-config EGLIBC_VERSION_2_10
- bool
- default y if EGLIBC_VERSION_2_10_1
diff --git a/toolchain/eglibc/Makefile b/toolchain/eglibc/Makefile
index 0363dd9061..b72b4bd356 100644
--- a/toolchain/eglibc/Makefile
+++ b/toolchain/eglibc/Makefile
@@ -15,22 +15,22 @@ PKG_SOURCE_VERSION:=$(PKG_REVISION)
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)-r$(PKG_REVISION)
PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.bz2
-ifeq ($(PKG_VERSION),2.6.1)
+ifneq ($(CONFIG_EGLIBC_VERSION_2_6),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_6
endif
-ifeq ($(PKG_VERSION),2.7)
+ifneq ($(CONFIG_EGLIBC_VERSION_2_7),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_7
endif
-ifeq ($(PKG_VERSION),2.8)
+ifneq ($(CONFIG_EGLIBC_VERSION_2_8),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_8
endif
-ifeq ($(PKG_VERSION),2.9)
+ifneq ($(CONFIG_EGLIBC_VERSION_2_9),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_9
endif
-ifeq ($(PKG_VERSION),2.10.1)
+ifneq ($(CONFIG_EGLIBC_VERSION_2_10),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_10
endif
-ifeq ($(PKG_VERSION),trunk)
+ifneq ($(CONFIG_EGLIBC_VERSION_TRUNK),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/trunk
endif