aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/eglibc/common.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-02-07 17:34:53 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-02-07 17:34:53 +0000
commit5c8783e02a544544c9b7fe432c8fd248eb11e08f (patch)
tree86217056706841e41298ca756ee2e3a0e453281a /toolchain/eglibc/common.mk
parent5393efc0c7bef3c13f5c32d6a6507ba485fd7f00 (diff)
downloadupstream-5c8783e02a544544c9b7fe432c8fd248eb11e08f.tar.gz
upstream-5c8783e02a544544c9b7fe432c8fd248eb11e08f.tar.bz2
upstream-5c8783e02a544544c9b7fe432c8fd248eb11e08f.zip
toolchain/eglibc: add support for 2.17
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 35515
Diffstat (limited to 'toolchain/eglibc/common.mk')
-rw-r--r--toolchain/eglibc/common.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/toolchain/eglibc/common.mk b/toolchain/eglibc/common.mk
index 5c8dc117ec..483f57db82 100644
--- a/toolchain/eglibc/common.mk
+++ b/toolchain/eglibc/common.mk
@@ -21,6 +21,9 @@ endif
ifneq ($(CONFIG_EGLIBC_VERSION_2_16),)
PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_16
endif
+ifneq ($(CONFIG_EGLIBC_VERSION_2_17),)
+ PKG_SOURCE_URL:=svn://svn.eglibc.org/branches/eglibc-2_17
+endif
PATCH_DIR:=$(PATH_PREFIX)/patches/$(PKG_VERSION)
@@ -80,7 +83,9 @@ define Host/Prepare
$(call Host/Prepare/Default)
ln -snf $(PKG_SOURCE_SUBDIR) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
$(SED) 's,y,n,' $(HOST_BUILD_DIR)/libc/option-groups.defaults
+ifneq ($(CONFIG_EGLIBC_VERSION_2_17),y)
ln -sf ../ports $(HOST_BUILD_DIR)/libc/
+endif
endef
define Host/Clean