aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-05-03 15:01:03 +0200
committerFelix Fietkau <nbd@nbd.name>2017-05-25 19:01:07 +0200
commitf62f4b3c5c9d059a2e6a1e80ce7b4267ef0c236b (patch)
tree96563a32e7c0f1b7d96bae85defb7f17bae626ec /toolchain/binutils
parenta76cbc0d7ec2a816682063bdc18d114ec0711113 (diff)
downloadupstream-f62f4b3c5c9d059a2e6a1e80ce7b4267ef0c236b.tar.gz
upstream-f62f4b3c5c9d059a2e6a1e80ce7b4267ef0c236b.tar.bz2
upstream-f62f4b3c5c9d059a2e6a1e80ce7b4267ef0c236b.zip
build: stop overriding STAGING_DIR_HOST for toolchain build
This causes various issues in other places that assume that host binaries are staged in STAGING_DIR_HOST. Since all the right places use HOST_BUILD_PREFIX, override that instead. This fixes some issues with quilt on toolchain dirs Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 9bdd68f6ac..459f54587b 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -34,8 +34,6 @@ HOST_BUILD_PARALLEL:=1
PATCH_DIR:=./patches/$(PKG_VERSION)
-REAL_STAGING_DIR_HOST:=$(STAGING_DIR_HOST)
-
include $(INCLUDE_DIR)/toolchain-build.mk
BINUTILS_CONFIGURE:= \
@@ -96,7 +94,7 @@ define Host/Install
install
$(call FixupLibdir,$(TOOLCHAIN_DIR)/initial)
$(RM) $(TOOLCHAIN_DIR)/initial/lib/libiberty.a
- $(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(REAL_STAGING_DIR_HOST)/bin/readelf
+ $(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(HOST_BUILD_PREFIX)/bin/readelf
# ARC gcc requires extlib.
# If extlib is not available in "initial" folder
# initial gcc will fail to build libc.