aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorEvgeniy Didin <Evgeniy.Didin@synopsys.com>2018-01-24 20:26:03 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2018-01-27 16:46:44 +0100
commite47fe3284f25c0d7354f239ea8424b96dfe5b36d (patch)
tree3d7664b58bf65eee13543aee8fa0848036cd25c9 /toolchain/binutils
parent53021ce7f24b0fd80a6f50517a25d762d783102b (diff)
downloadupstream-e47fe3284f25c0d7354f239ea8424b96dfe5b36d.tar.gz
upstream-e47fe3284f25c0d7354f239ea8424b96dfe5b36d.tar.bz2
upstream-e47fe3284f25c0d7354f239ea8424b96dfe5b36d.zip
toolchain/arc: update to the most recent release arc-2017.09
This commit finally bumps ARC tools to the most recent arc-2017.09 release version. ARC GNU tools of version arc-2017.09 bring some quite significant changes like: * Binutils v2.29 with additional ARC patches * GCC 7.1.1 with additional ARC patches More information on this release could be found here: https://github.com/foss-for-synopsys-dwc-arc-processors/toolchain/releases/tag/arc-2017.09-release Signed-off-by: Evgeniy Didin <Evgeniy.Didin@synopsys.com> CC: Alexey Brodkin <abrodkin@synopsys.com> CC: John Crispin <john@phrozen.org>
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Config.in8
-rw-r--r--toolchain/binutils/Config.version4
-rw-r--r--toolchain/binutils/Makefile6
3 files changed, 9 insertions, 9 deletions
diff --git a/toolchain/binutils/Config.in b/toolchain/binutils/Config.in
index 25f721a6b5..56bcd162a2 100644
--- a/toolchain/binutils/Config.in
+++ b/toolchain/binutils/Config.in
@@ -3,7 +3,7 @@
choice
prompt "Binutils Version" if TOOLCHAINOPTS
default BINUTILS_USE_VERSION_2_28 if !arc
- default BINUTILS_USE_VERSION_2_28_ARC if arc
+ default BINUTILS_USE_VERSION_2_29_ARC if arc
help
Select the version of binutils you wish to use.
@@ -17,10 +17,10 @@ choice
bool "Binutils 2.28"
select BINUTILS_VERSION_2_28
- config BINUTILS_USE_VERSION_2_28_ARC
+ config BINUTILS_USE_VERSION_2_29_ARC
depends on arc
- bool "ARC binutils 2.28"
- select BINUTILS_VERSION_2_28_ARC
+ bool "ARC binutils 2.29"
+ select BINUTILS_VERSION_2_29_ARC
config BINUTILS_USE_VERSION_2_29_1
depends on !arc
diff --git a/toolchain/binutils/Config.version b/toolchain/binutils/Config.version
index 54df1730c7..159a25f10f 100644
--- a/toolchain/binutils/Config.version
+++ b/toolchain/binutils/Config.version
@@ -5,7 +5,7 @@ config BINUTILS_VERSION_2_28
default y if (!TOOLCHAINOPTS && !arc)
bool
-config BINUTILS_VERSION_2_28_ARC
+config BINUTILS_VERSION_2_29_ARC
default y if (!TOOLCHAINOPTS && arc)
bool
@@ -17,4 +17,4 @@ config BINUTILS_VERSION
default "2.27" if BINUTILS_VERSION_2_27
default "2.28" if BINUTILS_VERSION_2_28
default "2.29.1" if BINUTILS_VERSION_2_29_1
- default "arc-2017.03" if BINUTILS_VERSION_2_28_ARC
+ default "arc-2017.09" if BINUTILS_VERSION_2_29_ARC
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index fd4af5c25c..c46d29933d 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -25,11 +25,11 @@ ifeq ($(PKG_VERSION),2.29.1)
PKG_HASH:=1509dff41369fb70aed23682351b663b56db894034773e6dbf7d5d6071fc55cc
endif
-ifneq ($(CONFIG_BINUTILS_VERSION_2_28_ARC),)
- PKG_REV:=arc-2017.03-release
+ifneq ($(CONFIG_BINUTILS_VERSION_2_29_ARC),)
+ PKG_REV:=arc-2017.09-release
PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/$(PKG_REV)/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_REV).tar.gz
- PKG_HASH:=f9c1e09ef10aaf9619181f49587f464ba0a70d29b7f6f879047140acac852409
+ PKG_HASH:=2ea086fd5521e942926dd6ff6922ce31c29ee7ffc754fca3d06385e0f27600f8
BINUTILS_DIR:=$(PKG_NAME)-gdb-$(PKG_REV)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
endif