aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>2016-05-19 08:20:33 +0300
committerFelix Fietkau <nbd@nbd.name>2016-05-19 19:29:44 +0200
commitd354bfde174514973309e788e11c286f1667c2f5 (patch)
treec71bdb107387fb9c9aedce9b93f8cabbf5ab2378 /toolchain/binutils
parent8d105653b13eb5f56764c8e02f307f4d28a6a3a7 (diff)
downloadupstream-d354bfde174514973309e788e11c286f1667c2f5.tar.gz
upstream-d354bfde174514973309e788e11c286f1667c2f5.tar.bz2
upstream-d354bfde174514973309e788e11c286f1667c2f5.zip
toolchain: Bump ARC tools to arc-2016.03
This change switches ARC tools to the most recent arc-2016.03 version. ARC GNU tools of version arc-2016.03 bring some quite significant changes like: * Binutils v2.26+ (upstream commit id 202ac19 with additional ARC * patches) * GCC v4.8.5 * GDB 7.10 More about changes, improvements and fixes could be found here: https://github.com/foss-for-synopsys-dwc-arc-processors/toolchain/releases/tag/arc-2016.03 Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Config.in8
-rw-r--r--toolchain/binutils/Config.version4
-rw-r--r--toolchain/binutils/Makefile8
-rw-r--r--toolchain/binutils/patches/arc-2016.03/200-arc-fix-target-mask.patch13
4 files changed, 23 insertions, 10 deletions
diff --git a/toolchain/binutils/Config.in b/toolchain/binutils/Config.in
index c32f43cdd4..2960c947d2 100644
--- a/toolchain/binutils/Config.in
+++ b/toolchain/binutils/Config.in
@@ -3,7 +3,7 @@
choice
prompt "Binutils Version" if TOOLCHAINOPTS
default BINUTILS_USE_VERSION_2_25_1 if !arc
- default BINUTILS_USE_VERSION_2_23_ARC if arc
+ default BINUTILS_USE_VERSION_2_26_ARC if arc
help
Select the version of binutils you wish to use.
@@ -17,10 +17,10 @@ choice
bool "Binutils 2.25.1"
select BINUTILS_VERSION_2_25_1
- config BINUTILS_USE_VERSION_2_23_ARC
+ config BINUTILS_USE_VERSION_2_26_ARC
depends on arc
- bool "ARC binutils 2.23"
- select BINUTILS_VERSION_2_23_ARC
+ bool "ARC binutils 2.26"
+ select BINUTILS_VERSION_2_26_ARC
endchoice
diff --git a/toolchain/binutils/Config.version b/toolchain/binutils/Config.version
index bea748b902..fc7a1f37c0 100644
--- a/toolchain/binutils/Config.version
+++ b/toolchain/binutils/Config.version
@@ -5,7 +5,7 @@ config BINUTILS_VERSION_2_25_1
default y if (!TOOLCHAINOPTS && !arc)
bool
-config BINUTILS_VERSION_2_23_ARC
+config BINUTILS_VERSION_2_26_ARC
default y if (!TOOLCHAINOPTS && arc)
bool
@@ -13,5 +13,5 @@ config BINUTILS_VERSION
string
default "2.24-linaro" if BINUTILS_VERSION_2_24_LINARO
default "2.25.1" if BINUTILS_VERSION_2_25_1
- default "arc-2015.06" if BINUTILS_VERSION_2_23_ARC
+ default "arc-2016.03" if BINUTILS_VERSION_2_26_ARC
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index c37148eedd..03fc76abdd 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -26,11 +26,11 @@ ifeq ($(findstring linaro, $(CONFIG_BINUTILS_VERSION)),linaro)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
endif
-ifneq ($(CONFIG_BINUTILS_VERSION_2_23_ARC),)
- PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/arc-2015.06/
- PKG_REV:=2015.06
+ifneq ($(CONFIG_BINUTILS_VERSION_2_26_ARC),)
+ PKG_SOURCE_URL:=https://github.com/foss-for-synopsys-dwc-arc-processors/binutils-gdb/archive/arc-2016.03/
+ PKG_REV:=2016.03
PKG_SOURCE:=$(PKG_NAME)-arc-$(PKG_REV).tar.gz
- PKG_MD5SUM:=961a3564de857238c255c381f8e4360b
+ PKG_MD5SUM:=d4387bab089df77a8049c81980b9fa12
BINUTILS_DIR:=$(PKG_NAME)-gdb-arc-$(PKG_REV)
HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
endif
diff --git a/toolchain/binutils/patches/arc-2016.03/200-arc-fix-target-mask.patch b/toolchain/binutils/patches/arc-2016.03/200-arc-fix-target-mask.patch
new file mode 100644
index 0000000000..7e51d588ae
--- /dev/null
+++ b/toolchain/binutils/patches/arc-2016.03/200-arc-fix-target-mask.patch
@@ -0,0 +1,13 @@
+diff --git a/bfd/config.bfd b/bfd/config.bfd
+index 5145d4a..a9c9c99 100644
+--- a/bfd/config.bfd
++++ b/bfd/config.bfd
+@@ -275,7 +275,7 @@ case "${targ}" in
+ targ_defvec=am33_elf32_linux_vec
+ ;;
+
+- arc*-*-elf* | arc*-*-linux-uclibc*)
++ arc*-*-elf* | arc*-*-linux-*)
+ targ_defvec=arc_elf32_le_vec
+ targ_selvecs=arc_elf32_be_vec
+ ;;