aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2019-04-22 15:22:40 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-11 23:10:10 +0200
commitaecd0e09c940219c163d79ffa42e2a935df7db8c (patch)
tree644a3c163769ee28447acaaf046d634c0e1b1d6b /toolchain/binutils
parent0b2638253321db90e9844f04cd7299c1a2e1633a (diff)
downloadupstream-aecd0e09c940219c163d79ffa42e2a935df7db8c.tar.gz
upstream-aecd0e09c940219c163d79ffa42e2a935df7db8c.tar.bz2
upstream-aecd0e09c940219c163d79ffa42e2a935df7db8c.zip
toolchain/binutils: use default Host/Configure rule
This seems to have been omitted over-time. Using the default Host/Configure seems to work fine. The last patches to have touched this in a major way were ~10 years ago: 33a0eb3613d ("cosmetic & coherency fixes") 7eb15898755 ("build system refactoring in preparation for allowing packages to do host-build steps") Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Makefile45
1 files changed, 19 insertions, 26 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 1a0b1bce05..24eaf70566 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -33,34 +33,33 @@ PATCH_DIR:=./patches/$(PKG_VERSION)
include $(INCLUDE_DIR)/toolchain-build.mk
-BINUTILS_CONFIGURE:= \
- ./configure \
- --prefix=$(TOOLCHAIN_DIR) \
- --build=$(GNU_HOST_NAME) \
- --host=$(GNU_HOST_NAME) \
- --target=$(REAL_GNU_TARGET_NAME) \
- --with-sysroot=$(TOOLCHAIN_DIR) \
- --enable-deterministic-archives \
- --enable-plugins \
- --disable-multilib \
- --disable-werror \
- --disable-nls \
- --disable-sim \
- --disable-gdb \
- $(GRAPHITE_CONFIGURE) \
- $(SOFT_FLOAT_CONFIG_OPTION) \
- $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS))
+HOST_CONFIGURE_ARGS = \
+ --prefix=$(TOOLCHAIN_DIR) \
+ --build=$(GNU_HOST_NAME) \
+ --host=$(GNU_HOST_NAME) \
+ --target=$(REAL_GNU_TARGET_NAME) \
+ --with-sysroot=$(TOOLCHAIN_DIR) \
+ --enable-deterministic-archives \
+ --enable-plugins \
+ --disable-multilib \
+ --disable-werror \
+ --disable-nls \
+ --disable-sim \
+ --disable-gdb \
+ $(GRAPHITE_CONFIGURE) \
+ $(SOFT_FLOAT_CONFIG_OPTION) \
+ $(call qstrip,$(CONFIG_EXTRA_BINUTILS_CONFIG_OPTIONS))
ifneq ($(CONFIG_SSP_SUPPORT),)
- BINUTILS_CONFIGURE+= \
+ HOST_CONFIGURE_ARGS+= \
--enable-libssp
else
- BINUTILS_CONFIGURE+= \
+ HOST_CONFIGURE_ARGS+= \
--disable-libssp
endif
ifneq ($(CONFIG_EXTRA_TARGET_ARCH),)
- BINUTILS_CONFIGURE+= \
+ HOST_CONFIGURE_ARGS+= \
--enable-targets=$(call qstrip,$(CONFIG_EXTRA_TARGET_ARCH_NAME))-linux-$(TARGET_SUFFIX)
endif
@@ -71,12 +70,6 @@ define Host/Prepare
$(SED) 's, " Linaro.*,,' $(HOST_BUILD_DIR)/bfd/version.h
endef
-define Host/Configure
- (cd $(HOST_BUILD_DIR); \
- $(BINUTILS_CONFIGURE) \
- );
-endef
-
define Host/Compile
+$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) all
endef