aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2020-02-03 15:30:06 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2020-02-22 16:38:41 +0100
commit53470bdf3212136df06a26d33377059eb56b09eb (patch)
tree3f44c13912daa0fabd710b73c51b763ec8c74b4f /toolchain/binutils
parentf0864cb31be59c550625379d3f60aa1b61743b4f (diff)
downloadupstream-53470bdf3212136df06a26d33377059eb56b09eb.tar.gz
upstream-53470bdf3212136df06a26d33377059eb56b09eb.tar.bz2
upstream-53470bdf3212136df06a26d33377059eb56b09eb.zip
toolchain/binutils: Add binutils 2.34
Refresh patches Drop 300-012_check_ldrunpath_length.patch Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/Config.in3
-rw-r--r--toolchain/binutils/Config.version11
-rw-r--r--toolchain/binutils/Makefile4
-rw-r--r--toolchain/binutils/patches/2.34/300-001_ld_makefile_patch.patch22
-rw-r--r--toolchain/binutils/patches/2.34/400-mips_no_dynamic_linking_sym.patch18
-rw-r--r--toolchain/binutils/patches/2.34/500-Change-default-emulation-for-mips64-linux.patch38
6 files changed, 93 insertions, 3 deletions
diff --git a/toolchain/binutils/Config.in b/toolchain/binutils/Config.in
index 685e89be96..4ae0b57572 100644
--- a/toolchain/binutils/Config.in
+++ b/toolchain/binutils/Config.in
@@ -21,6 +21,9 @@ choice
bool "Binutils 2.32"
select BINUTILS_VERSION_2_32
+ config BINUTILS_USE_VERSION_2_34
+ bool "Binutils 2.34"
+ select BINUTILS_VERSION_2_34
endchoice
config EXTRA_BINUTILS_CONFIG_OPTIONS
diff --git a/toolchain/binutils/Config.version b/toolchain/binutils/Config.version
index 3ffcf57347..7c3519680d 100644
--- a/toolchain/binutils/Config.version
+++ b/toolchain/binutils/Config.version
@@ -9,8 +9,13 @@ config BINUTILS_VERSION_2_32
default y if (!TOOLCHAINOPTS && arc)
bool
+config BINUTILS_VERSION_2_34
+ default y if (!TOOLCHAINOPTS && arc)
+ bool
+
config BINUTILS_VERSION
string
- default "2.29.1" if BINUTILS_VERSION_2_29_1
- default "2.31.1" if BINUTILS_VERSION_2_31_1
- default "2.32" if BINUTILS_VERSION_2_32
+ default "2.29.1" if BINUTILS_VERSION_2_29_1
+ default "2.31.1" if BINUTILS_VERSION_2_31_1
+ default "2.32" if BINUTILS_VERSION_2_32
+ default "2.34" if BINUTILS_VERSION_2_34
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 24eaf70566..c5c8bf588c 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -27,6 +27,10 @@ ifeq ($(PKG_VERSION),2.32)
PKG_HASH:=0ab6c55dd86a92ed561972ba15b9b70a8b9f75557f896446c82e8b36e473ee04
endif
+ifeq ($(PKG_VERSION),2.34)
+ PKG_HASH:=f00b0e8803dc9bab1e2165bd568528135be734df3fabf8d0161828cd56028952
+endif
+
HOST_BUILD_PARALLEL:=1
PATCH_DIR:=./patches/$(PKG_VERSION)
diff --git a/toolchain/binutils/patches/2.34/300-001_ld_makefile_patch.patch b/toolchain/binutils/patches/2.34/300-001_ld_makefile_patch.patch
new file mode 100644
index 0000000000..dcffe00941
--- /dev/null
+++ b/toolchain/binutils/patches/2.34/300-001_ld_makefile_patch.patch
@@ -0,0 +1,22 @@
+--- a/ld/Makefile.am
++++ b/ld/Makefile.am
+@@ -63,7 +63,7 @@ endif
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@
+--- a/ld/Makefile.in
++++ b/ld/Makefile.in
+@@ -572,7 +572,7 @@ AM_CFLAGS = $(WARN_CFLAGS) $(ELF_CLFAGS)
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ BASEDIR = $(srcdir)/..
+ BFDDIR = $(BASEDIR)/bfd
+ INCDIR = $(BASEDIR)/include
diff --git a/toolchain/binutils/patches/2.34/400-mips_no_dynamic_linking_sym.patch b/toolchain/binutils/patches/2.34/400-mips_no_dynamic_linking_sym.patch
new file mode 100644
index 0000000000..a973c56b13
--- /dev/null
+++ b/toolchain/binutils/patches/2.34/400-mips_no_dynamic_linking_sym.patch
@@ -0,0 +1,18 @@
+--- a/bfd/elfxx-mips.c
++++ b/bfd/elfxx-mips.c
+@@ -8092,6 +8092,7 @@ _bfd_mips_elf_create_dynamic_sections (b
+
+ name = SGI_COMPAT (abfd) ? "_DYNAMIC_LINK" : "_DYNAMIC_LINKING";
+ bh = NULL;
++ if (0) {
+ if (!(_bfd_generic_link_add_one_symbol
+ (info, abfd, name, BSF_GLOBAL, bfd_abs_section_ptr, 0,
+ NULL, FALSE, get_elf_backend_data (abfd)->collect, &bh)))
+@@ -8104,6 +8105,7 @@ _bfd_mips_elf_create_dynamic_sections (b
+
+ if (! bfd_elf_link_record_dynamic_symbol (info, h))
+ return FALSE;
++ }
+
+ if (! mips_elf_hash_table (info)->use_rld_obj_head)
+ {
diff --git a/toolchain/binutils/patches/2.34/500-Change-default-emulation-for-mips64-linux.patch b/toolchain/binutils/patches/2.34/500-Change-default-emulation-for-mips64-linux.patch
new file mode 100644
index 0000000000..24c2afb8be
--- /dev/null
+++ b/toolchain/binutils/patches/2.34/500-Change-default-emulation-for-mips64-linux.patch
@@ -0,0 +1,38 @@
+--- a/bfd/config.bfd
++++ b/bfd/config.bfd
+@@ -911,12 +911,12 @@ case "${targ}" in
+ targ_selvecs="mips_elf32_le_vec mips_elf64_be_vec mips_elf64_le_vec mips_ecoff_be_vec mips_ecoff_le_vec"
+ ;;
+ mips64*el-*-linux*)
+- targ_defvec=mips_elf32_ntrad_le_vec
+- targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_le_vec mips_elf64_trad_be_vec"
++ targ_defvec=mips_elf64_trad_le_vec
++ targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_be_vec"
+ ;;
+ mips64*-*-linux*)
+- targ_defvec=mips_elf32_ntrad_be_vec
+- targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_be_vec mips_elf64_trad_le_vec"
++ targ_defvec=mips_elf64_trad_be_vec
++ targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_le_vec"
+ ;;
+ mips*el-*-linux*)
+ targ_defvec=mips_elf32_trad_le_vec
+--- a/ld/configure.tgt
++++ b/ld/configure.tgt
+@@ -541,12 +541,12 @@ mips*-*-vxworks*) targ_emul=elf32ebmipvx
+ ;;
+ mips*-*-windiss) targ_emul=elf32mipswindiss
+ ;;
+-mips64*el-*-linux-*) targ_emul=elf32ltsmipn32
+- targ_extra_emuls="elf32btsmipn32 elf32ltsmip elf32btsmip elf64ltsmip elf64btsmip"
++mips64*el-*-linux-*) targ_emul=lf64ltsmip
++ targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32ltsmip elf32btsmip elf64btsmip"
+ targ_extra_libpath=$targ_extra_emuls
+ ;;
+-mips64*-*-linux-*) targ_emul=elf32btsmipn32
+- targ_extra_emuls="elf32ltsmipn32 elf32btsmip elf32ltsmip elf64btsmip elf64ltsmip"
++mips64*-*-linux-*) targ_emul=elf64btsmip
++ targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32btsmip elf32ltsmip elf64ltsmip"
+ targ_extra_libpath=$targ_extra_emuls
+ ;;
+ mips*el-*-linux-*) targ_emul=elf32ltsmip