aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/patches/2.23.1
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-02-26 16:40:12 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-02-26 16:40:12 +0000
commitd417049c4aa711a6b30ea7e14fbf4aca44142661 (patch)
treebfa689ff87dc5795bcea1bcb95f06733c2b81982 /toolchain/binutils/patches/2.23.1
parentbfcbabdf159f291f98683d802bff519781cb4fd9 (diff)
downloadupstream-d417049c4aa711a6b30ea7e14fbf4aca44142661.tar.gz
upstream-d417049c4aa711a6b30ea7e14fbf4aca44142661.tar.bz2
upstream-d417049c4aa711a6b30ea7e14fbf4aca44142661.zip
toolchain/binutils: refresh patches
Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 35812
Diffstat (limited to 'toolchain/binutils/patches/2.23.1')
-rw-r--r--toolchain/binutils/patches/2.23.1/112-arm-uclibc-gas-needs-libm.patch4
-rw-r--r--toolchain/binutils/patches/2.23.1/120-sh-conf.patch4
-rw-r--r--toolchain/binutils/patches/2.23.1/300-001_ld_makefile_patch.patch2
-rw-r--r--toolchain/binutils/patches/2.23.1/300-012_check_ldrunpath_length.patch4
4 files changed, 7 insertions, 7 deletions
diff --git a/toolchain/binutils/patches/2.23.1/112-arm-uclibc-gas-needs-libm.patch b/toolchain/binutils/patches/2.23.1/112-arm-uclibc-gas-needs-libm.patch
index a9e435701e..5d0e5ff8ef 100644
--- a/toolchain/binutils/patches/2.23.1/112-arm-uclibc-gas-needs-libm.patch
+++ b/toolchain/binutils/patches/2.23.1/112-arm-uclibc-gas-needs-libm.patch
@@ -20,7 +20,7 @@ make[4]: *** [as-new] Error 1
--- a/gas/configure.tgt
+++ b/gas/configure.tgt
-@@ -428,6 +428,12 @@ case ${generic_target} in
+@@ -450,6 +450,12 @@ case ${generic_target} in
*-*-netware) fmt=elf em=netware ;;
esac
@@ -31,5 +31,5 @@ make[4]: *** [as-new] Error 1
+esac
+
case ${cpu_type} in
- alpha | arm | i386 | ia64 | microblaze | mips | ns32k | pdp11 | ppc | sparc | z80 | z8k)
+ aarch64 | alpha | arm | i386 | ia64 | microblaze | mips | ns32k | pdp11 | ppc | sparc | z80 | z8k)
bfd_gas=yes
diff --git a/toolchain/binutils/patches/2.23.1/120-sh-conf.patch b/toolchain/binutils/patches/2.23.1/120-sh-conf.patch
index d92ceb52cf..ce0ec81b89 100644
--- a/toolchain/binutils/patches/2.23.1/120-sh-conf.patch
+++ b/toolchain/binutils/patches/2.23.1/120-sh-conf.patch
@@ -1,6 +1,6 @@
--- a/configure
+++ b/configure
-@@ -3570,7 +3570,7 @@ case "${target}" in
+@@ -3595,7 +3595,7 @@ case "${target}" in
mips*-*-*)
noconfigdirs="$noconfigdirs gprof"
;;
@@ -11,7 +11,7 @@
;;
--- a/configure.ac
+++ b/configure.ac
-@@ -1006,7 +1006,7 @@ case "${target}" in
+@@ -1021,7 +1021,7 @@ case "${target}" in
mips*-*-*)
noconfigdirs="$noconfigdirs gprof"
;;
diff --git a/toolchain/binutils/patches/2.23.1/300-001_ld_makefile_patch.patch b/toolchain/binutils/patches/2.23.1/300-001_ld_makefile_patch.patch
index aa853ff542..323655a01c 100644
--- a/toolchain/binutils/patches/2.23.1/300-001_ld_makefile_patch.patch
+++ b/toolchain/binutils/patches/2.23.1/300-001_ld_makefile_patch.patch
@@ -11,7 +11,7 @@
EMULATION_OFILES = @EMULATION_OFILES@
--- a/ld/Makefile.in
+++ b/ld/Makefile.in
-@@ -366,7 +366,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
+@@ -367,7 +367,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
# We put the scripts in the directory $(scriptdir)/ldscripts.
# We can't put the scripts in $(datadir) because the SEARCH_DIR
# directives need to be different for native and cross linkers.
diff --git a/toolchain/binutils/patches/2.23.1/300-012_check_ldrunpath_length.patch b/toolchain/binutils/patches/2.23.1/300-012_check_ldrunpath_length.patch
index 1e04000340..7e90d220a4 100644
--- a/toolchain/binutils/patches/2.23.1/300-012_check_ldrunpath_length.patch
+++ b/toolchain/binutils/patches/2.23.1/300-012_check_ldrunpath_length.patch
@@ -1,6 +1,6 @@
--- a/ld/emultempl/elf32.em
+++ b/ld/emultempl/elf32.em
-@@ -1273,6 +1273,8 @@ fragment <<EOF
+@@ -1274,6 +1274,8 @@ fragment <<EOF
&& command_line.rpath == NULL)
{
lib_path = (const char *) getenv ("LD_RUN_PATH");
@@ -9,7 +9,7 @@
if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
force))
break;
-@@ -1500,6 +1502,8 @@ gld${EMULATION_NAME}_before_allocation (
+@@ -1501,6 +1503,8 @@ gld${EMULATION_NAME}_before_allocation (
rpath = command_line.rpath;
if (rpath == NULL)
rpath = (const char *) getenv ("LD_RUN_PATH");