aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/binutils/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-09-11 17:58:39 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-09-11 17:58:39 +0000
commit98e00f8fdd92174aad58612107fd2cee06fbe036 (patch)
tree53826aa951c0f2d9c5cda2e88f674b816fb87d9f /toolchain/binutils/Makefile
parent0fdb4a458b08a802302801915801685b62c16f10 (diff)
downloadupstream-98e00f8fdd92174aad58612107fd2cee06fbe036.tar.gz
upstream-98e00f8fdd92174aad58612107fd2cee06fbe036.tar.bz2
upstream-98e00f8fdd92174aad58612107fd2cee06fbe036.zip
binutils: add binutils 2.25.1
This adds binutils 2.25.1 as an option to OpenWrt. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 46874
Diffstat (limited to 'toolchain/binutils/Makefile')
-rw-r--r--toolchain/binutils/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/toolchain/binutils/Makefile b/toolchain/binutils/Makefile
index 02765126e9..0028a02d68 100644
--- a/toolchain/binutils/Makefile
+++ b/toolchain/binutils/Makefile
@@ -10,12 +10,21 @@ PKG_NAME:=binutils
PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
BIN_VERSION:=$(PKG_VERSION)
-PKG_SOURCE_URL:=https://releases.linaro.org/14.09/components/toolchain/binutils-linaro/
-PKG_REV:=2.24.0-2014.09
-PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.xz
-PKG_MD5SUM:=8f9b2b2e049d59b1b86ce9657802a353
-BINUTILS_DIR:=$(PKG_NAME)-linaro-$(PKG_REV)
-HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
+ifeq ($(findstring linaro, $(CONFIG_BINUTILS_VERSION)),linaro)
+ PKG_SOURCE_URL:=https://releases.linaro.org/14.09/components/toolchain/binutils-linaro/
+ PKG_REV:=2.24.0-2014.09
+ PKG_SOURCE:=$(PKG_NAME)-linaro-$(PKG_REV).tar.xz
+ PKG_MD5SUM:=8f9b2b2e049d59b1b86ce9657802a353
+ BINUTILS_DIR:=$(PKG_NAME)-linaro-$(PKG_REV)
+ HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(BINUTILS_DIR)
+else
+ PKG_SOURCE_URL:=@GNU/binutils/
+ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+
+ ifeq ($(PKG_VERSION),2.25.1)
+ PKG_MD5SUM:=ac493a78de4fee895961d025b7905be4
+ endif
+endif
HOST_BUILD_PARALLEL:=1