aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-03-02 14:12:18 +0100
committerFelix Fietkau <nbd@nbd.name>2019-08-12 11:43:39 +0200
commitfdb30eed03ae56cd87078b64d9b2fac00799e783 (patch)
tree6e56fe2b2fbfcbb41641dd7c1f97b3000f317e0c /toolchain/Makefile
parent6fa0e07758524eddf20c9b66dfcb55c490e1961e (diff)
downloadupstream-fdb30eed03ae56cd87078b64d9b2fac00799e783.tar.gz
upstream-fdb30eed03ae56cd87078b64d9b2fac00799e783.tar.bz2
upstream-fdb30eed03ae56cd87078b64d9b2fac00799e783.zip
toolchain: add autoconf-lean
Use it to generate a more comprehensive configure sitefile Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 23a5529eed..1199b61749 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -29,7 +29,7 @@
curdir:=toolchain
# subdirectories to descend into
-$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_NASM),nasm)
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_NASM),nasm) autoconf-lean
ifdef CONFIG_USE_UCLIBC
$(curdir)/builddirs += $(LIBC)/utils
endif
@@ -51,6 +51,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/compile
$(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile $(curdir)/kernel-headers/compile
$(curdir)/$(LIBC)/utils/compile:=$(curdir)/gcc/final/compile
+ $(curdir)/autoconf-lean/compile:=$(curdir)/gcc/final/compile
endif
ifndef DUMP_TARGET_DB