aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-28 13:29:03 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-28 13:29:03 +0000
commite143bed1f19b55c5eac38d78a5c98f478fca88fc (patch)
tree1f3f129a7786dd35da2414d624e8302cbdf08d7a /toolchain/Makefile
parent9c88ba80b9d566ab7e3dc752fa68ae82aed54212 (diff)
downloadupstream-e143bed1f19b55c5eac38d78a5c98f478fca88fc.tar.gz
upstream-e143bed1f19b55c5eac38d78a5c98f478fca88fc.tar.bz2
upstream-e143bed1f19b55c5eac38d78a5c98f478fca88fc.zip
build system fixes, more cleanup
SVN-Revision: 8207
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile65
1 files changed, 16 insertions, 49 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 48637c11bf..21d2b6876e 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -1,63 +1,30 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# Main makefile for the toolchain
#
-include $(TOPDIR)/rules.mk
-TARGETS-y:=kernel-headers
-TARGETS-$(CONFIG_GDB) += gdb
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
- TARGETS-y+=binutils gcc uClibc
-endif
-
-TARGETS_DOWNLOAD:=$(patsubst %,%-download,$(TARGETS-y))
-TARGETS_PREPARE:=$(patsubst %,%-prepare,$(TARGETS-y))
-TARGETS_COMPILE:=$(patsubst %,%-compile,$(TARGETS-y))
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS-y))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS-y))
-STAMP:=$(STAGING_DIR)/stampfiles/.toolchain_installed
+# subdirectories to descend into
+toolchain/builddirs := kernel-headers $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_NATIVE_TOOLCHAIN),,binutils gcc uClibc)
-all: install
-download: $(TARGETS_DOWNLOAD)
-compile: $(TARGETS_COMPILE)
-install: $(STAMP)
-clean: $(TARGETS_CLEAN)
-
-ifneq ($(shell $(SCRIPT_DIR)/timestamp.pl -p . $(STAMP)),$(STAMP))
- $(STAMP): $(TARGETS_INSTALL)
-endif
-
-uClibc-prepare: kernel-headers-prepare
+# builddir dependencies
+toolchain/uClibc/prepare:=toolchain/kernel-headers/prepare
ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
- binutils-prepare: uClibc-prepare
- gcc-prepare: binutils-install
- uClibc-compile: gcc-compile
+ toolchain/binutils/prepare:=toolchain/uClibc/prepare
+ toolchain/gcc/prepare:=toolchain/binutils/install
+ toolchain/uClibc/compile:=toolchain/gcc/compile
endif
-gcc-install: uClibc-install
-
-$(STAMP):
- mkdir -p $(shell dirname $@)
- touch $@
-
-$(STAGING_DIR)/$(REAL_GNU_TARGET_NAME):
- @mkdir -p $@
- @ln -sf ../lib $@/lib
-
-$(TOOLCHAIN_BUILD_DIR):
- @mkdir -p $@
+toolchain/gcc/install:=toolchain/uClibc/install
-%-prereq %-download %-clean %-refresh %-update: FORCE
- $(MAKE) -C $* $(patsubst $*-%,%,$@)
+# prerequisites for the individual targets
+toolchain/ := .config $(tools/stamp)
+toolchain//prepare = $(STAGING_DIR)/include-host/.done
+toolchain//compile = $(1)/prepare
+toolchain//install = $(1)/compile
-%-prepare: $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME) $(TOOLCHAIN_BUILD_DIR)
- $(MAKE) -C $* $(patsubst $*-%,%,$@)
+$(eval $(call stampfile,toolchain,toolchain))
+$(eval $(call subdir,toolchain))
-%-compile: %-prepare FORCE
- $(MAKE) -C $* $(patsubst $*-%,%,$@)
-
-%-install: %-compile FORCE
- $(MAKE) -C $* $(patsubst $*-%,%,$@)