aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-09-24 11:02:30 +0200
committerFelix Fietkau <nbd@nbd.name>2018-09-24 11:03:20 +0200
commitdee8804de05dfac3f528e902b9fc68ccd43ec9a1 (patch)
treed5b0bbbd483b7ada5625fbff82de60a91f42332b /toolchain/Makefile
parent4f277eb6402684ca79c9834e8eb30c0e93368e8b (diff)
downloadupstream-dee8804de05dfac3f528e902b9fc68ccd43ec9a1.tar.gz
upstream-dee8804de05dfac3f528e902b9fc68ccd43ec9a1.tar.bz2
upstream-dee8804de05dfac3f528e902b9fc68ccd43ec9a1.zip
build: drop buildbot toolchain rebuild check when not using git
The check cleans and rebuilds the toolchain if it changed on update. When building from a source tarball, it is reasonable to expect that there will be no updates, so no rebuild check is necessary Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 9432990f4f..0336b2f72c 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -70,6 +70,7 @@ endif
endif
ifdef CONFIG_BUILDBOT
+ifneq ($(wildcard $(TOPDIR)/.git),)
$(TOOLCHAIN_DIR)/stamp/.ver_check: $(TMP_DIR)/.build
cd "$(TOPDIR)"; git log --format=%h -1 toolchain > $(TMP_DIR)/.ver_check
cmp -s $(TMP_DIR)/.ver_check $@ || { \
@@ -80,6 +81,7 @@ ifdef CONFIG_BUILDBOT
$(TOOLCHAIN_DIR)/info.mk $(STAGING_DIR)/.prepared: $(TOOLCHAIN_DIR)/stamp/.ver_check
endif
+endif
# prerequisites for the individual targets
$(curdir)/ := .config prereq