aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-09-23 02:27:38 +0000
committerNicolas Thill <nico@openwrt.org>2009-09-23 02:27:38 +0000
commitc9bc7c504c61a0d935573c86657222b067037193 (patch)
treef46c8a4d3702a87cbf9554657bba8663a64579b9 /toolchain/Makefile
parent6f4e700acd737903c12fee0f0790f84c39a28a19 (diff)
downloadupstream-c9bc7c504c61a0d935573c86657222b067037193.tar.gz
upstream-c9bc7c504c61a0d935573c86657222b067037193.tar.bz2
upstream-c9bc7c504c61a0d935573c86657222b067037193.zip
add external toolchain support, enhance native toolchain support (special thanks to Luigi Mantellini for his help... and patience ;)
SVN-Revision: 17682
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 456b731fb8..161b139d74 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -28,13 +28,13 @@
curdir:=toolchain
# subdirectories to descend into
-$(curdir)/builddirs := kernel-headers $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_NATIVE_TOOLCHAIN),,binutils gcc $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),,kernel-headers binutils gcc $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
$(curdir)/builddirs-compile:=$($(curdir)/builddirs-prepare)
$(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)
# builddir dependencies
-$(curdir)/$(LIBC)/prepare:=$(curdir)/kernel-headers/install
-ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
+ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
+ $(curdir)/$(LIBC)/prepare:=$(curdir)/kernel-headers/install
$(curdir)/gcc/prepare:=$(curdir)/binutils/install
$(curdir)/kernel-headers/install:=$(curdir)/gcc/prepare
$(curdir)/gcc/compile:=$(curdir)/$(LIBC)/prepare