aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-03-28 12:16:39 +0000
committerLuka Perkov <luka@openwrt.org>2013-03-28 12:16:39 +0000
commitc0de55b32c435f5fbcdd783b6f58a9f1009939a4 (patch)
tree923b75eaecae6254365d0e936ae92e8641a3578b /toolchain/Makefile
parent98ef9e5411bfba94abc7db66d6e000122813dca8 (diff)
downloadupstream-c0de55b32c435f5fbcdd783b6f58a9f1009939a4.tar.gz
upstream-c0de55b32c435f5fbcdd783b6f58a9f1009939a4.tar.bz2
upstream-c0de55b32c435f5fbcdd783b6f58a9f1009939a4.zip
toolchain: stop generating broken symlink in TOOLCHAIN_DIR/lib
It turns out that the symlink may exists already by the time the toolchain Makefile gets an opportunity to run. While we asked to replace the target, ln doesn't do so until after dereferencing the existing symlink. This results in an unintended symlink that refers to itself. Instead, create the link without dereferencing any symlinks by using the -n option. Signed-off-by: John Szakmeister <john@szakmeister.net> SVN-Revision: 36140
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index bdfb29ec17..763381a838 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -63,7 +63,7 @@ ifneq ($(ARCH),)
$(if $(QUIET),,set -x;) \
mkdir -p "$$dir"; \
cd "$$dir"; \
- ln -sf lib lib64; \
+ ln -nsf lib lib64; \
mkdir -p stamp lib usr/include usr/lib ; \
); done
@grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@