aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-08-19 17:49:09 +0200
committerDaniel Golle <daniel@makrotopia.org>2016-08-19 17:53:50 +0200
commitc08651226f5645204f91f79d247801033f6015d1 (patch)
tree865b9e6d09a480afc2c209f3d973a2e636b3778d /toolchain/Makefile
parentf71f7f0df15a78a5793b8f8cdc6abff7563245e3 (diff)
downloadupstream-c08651226f5645204f91f79d247801033f6015d1.tar.gz
upstream-c08651226f5645204f91f79d247801033f6015d1.tar.bz2
upstream-c08651226f5645204f91f79d247801033f6015d1.zip
toolchain: include yasm in x86 toolchain
Some libraries require yasm to build with in-line assembly for x86 targets. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 7d2fddda31..a656a86b0d 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -29,7 +29,7 @@
curdir:=toolchain
# subdirectories to descend into
-$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers)
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_YASM),yasm)
ifdef CONFIG_USE_UCLIBC
$(curdir)/builddirs += $(LIBC)/utils
endif