aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke.mehrtens@intel.com>2019-07-23 16:53:51 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-08-05 23:22:26 +0200
commitb20156ba704ed8e03d030b2f294d8d19bebd2f71 (patch)
treec01496d821eac92b9a676c134012d22b784734d2 /toolchain/Makefile
parent2dca43b871629e418ba2116bcdb95c615fdf1626 (diff)
downloadupstream-b20156ba704ed8e03d030b2f294d8d19bebd2f71.tar.gz
upstream-b20156ba704ed8e03d030b2f294d8d19bebd2f71.tar.bz2
upstream-b20156ba704ed8e03d030b2f294d8d19bebd2f71.zip
toolchain: fix gcc depends on kernel headers
GCC needs the kernel headers to compile. Some GCC file includes asm/unistd.h which is provided by the kernel headers. Normally the kernel headers build is very fast and ready before the gcc uses it, but if it clones the kernel from a slow git repository it takes longer and then it could be that the gcc already wants to use the kernel headers before they are available. This patch fixes this problem by adding the missing dependency. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@intel.com>
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 0336b2f72c..23a5529eed 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -49,7 +49,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(curdir)/gcc/initial/compile+=$(curdir)/binutils/compile
$(curdir)/$(LIBC)/compile:=$(curdir)/gcc/initial/compile
- $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile
+ $(curdir)/gcc/final/compile:=$(curdir)/$(LIBC)/compile $(curdir)/kernel-headers/compile
$(curdir)/$(LIBC)/utils/compile:=$(curdir)/gcc/final/compile
endif