aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-08 19:55:42 +0000
commita9d683ca912b2c4837b2e65909c09ca01babe3df (patch)
tree6cbca6e13dd0bb18c9d9f1d4baa9a0ea7801b959 /toolchain/Makefile
parent4a2e4920b1d909ca254853b0dce46af3123e8f74 (diff)
downloadupstream-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.gz
upstream-a9d683ca912b2c4837b2e65909c09ca01babe3df.tar.bz2
upstream-a9d683ca912b2c4837b2e65909c09ca01babe3df.zip
major target cleanup. it is now possible to have subtargets that can override many target settings, including arch - merge adm5120, adm5120eb. target profiles still need to be adapted for subtargets
SVN-Revision: 8694
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 80bdf485df..cbc726ef01 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -39,6 +39,8 @@ $(curdir)//prepare = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk
$(curdir)//compile = $(1)/prepare
$(curdir)//install = $(1)/compile
-$(eval $(call stampfile,$(curdir),toolchain,install))
+$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed:
+
+$(eval $(call stampfile,$(curdir),toolchain,install,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed))
$(eval $(call subdir,$(curdir)))