aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-01-08 01:49:11 +0000
committerNicolas Thill <nico@openwrt.org>2009-01-08 01:49:11 +0000
commita3edea1b9136b05edfed95b58ba33a9ff46b6587 (patch)
treed770d58fd59fc61cac796defdba965d6e1af5f71 /toolchain/Makefile
parent001fd4384175d67eef5554613e6933ddb3c70585 (diff)
downloadupstream-a3edea1b9136b05edfed95b58ba33a9ff46b6587.tar.gz
upstream-a3edea1b9136b05edfed95b58ba33a9ff46b6587.tar.bz2
upstream-a3edea1b9136b05edfed95b58ba33a9ff46b6587.zip
add support for alternative C libraries (currently only glibc/eglibc) other (related) changes: - kernel headers are now installed using "make headers_install" on 2.6 - target names now contain an openwrt "vendor" tag (e.g. mips-openwrt-linux-gnu) - build directory names now contain gcc/libc name/version - default cpu for x86 is now i486 (required to build glibc/eglibc)
SVN-Revision: 13931
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile41
1 files changed, 32 insertions, 9 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 4afcc439a3..7762593ef6 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -1,26 +1,49 @@
#
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# Main makefile for the toolchain
#
+# Steps:
+# 1) toolchain/binutils/install
+# build & install binutils
+# 2) toolchain/gcc/prepare
+# build & install a minimal gcc, needed for steps 3 & 4
+# 3) toolchain/kernel-headers/install
+# install kernel headers, needed for step 4
+# 4) toolchain/libc/prepare
+# build & install libc headers & support files, needed for step 5
+# 5) toolchain/gcc/compile
+# build & install an initial gcc, needed for step 6
+# 6) toolchain/libc/compile
+# build & install the final libc
+# 7) toolchain/gcc/install
+# build & install the final gcc
+# 8) toolchain/libc/install
+# build & install libc utilities
+#
+
curdir:=toolchain
# subdirectories to descend into
-$(curdir)/builddirs := kernel-headers $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_NATIVE_TOOLCHAIN),,binutils gcc uClibc)
-$(curdir)/builddirs-compile:=. $(filter-out kernel-headers,$($(curdir)/builddirs))
+$(curdir)/builddirs := kernel-headers $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_NATIVE_TOOLCHAIN),,binutils gcc $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
+$(curdir)/builddirs-compile:=$($(curdir)/builddirs-prepare)
$(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)
# builddir dependencies
-$(curdir)/uClibc/prepare:=$(curdir)/kernel-headers/prepare
+$(curdir)/$(LIBC)/prepare:=$(curdir)/kernel-headers/install
ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
- $(curdir)/binutils/prepare:=$(curdir)/uClibc/prepare
$(curdir)/gcc/prepare:=$(curdir)/binutils/install
- $(curdir)/uClibc/compile:=$(curdir)/gcc/compile
- $(curdir)/gcc/install:=$(curdir)/uClibc/compile
- $(curdir)/uClibc/install:=$(curdir)/gcc/install
+ $(curdir)/kernel-headers/install:=$(curdir)/gcc/prepare
+ $(curdir)/gcc/compile:=$(curdir)/$(LIBC)/prepare
+ $(curdir)/$(LIBC)/compile:=$(curdir)/gcc/compile
+ $(curdir)/gcc/install:=$(curdir)/$(LIBC)/compile
+ $(curdir)/$(LIBC)/install:=$(curdir)/gcc/install
+ ifneq ($(CONFIG_GLIBC_PORTS),)
+ $(curdir)/glibc/prepare:=$(curdir)/glibc-ports/prepare
+ endif
endif
ifneq ($(ARCH),)
@@ -29,7 +52,7 @@ ifneq ($(ARCH),)
set -x; \
mkdir -p "$$dir"; \
cd "$$dir"; \
- mkdir -p bin lib include stamp; \
+ mkdir -p stamp lib usr/include usr/lib ; \
); done
@grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
@touch $@