aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-07-30 21:57:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-07-30 21:57:14 +0000
commita37c85d5fe575cf36531ba255976d9fed5fcdbf5 (patch)
tree8af94d06121f05e58ae051169013b25f26e82d7b /toolchain/Makefile
parent7b6d8470c6446f98afe2aa9db91936328f60cc26 (diff)
downloadupstream-a37c85d5fe575cf36531ba255976d9fed5fcdbf5.tar.gz
upstream-a37c85d5fe575cf36531ba255976d9fed5fcdbf5.tar.bz2
upstream-a37c85d5fe575cf36531ba255976d9fed5fcdbf5.zip
no need to call compile,install on the kernel-headers dir - this gets rid of another unnecessary autorebuild check
SVN-Revision: 8247
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 9e3a781384..b11653190e 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -10,6 +10,8 @@ curdir:=toolchain
# subdirectories to descend into
$(curdir)/builddirs := kernel-headers $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_NATIVE_TOOLCHAIN),,binutils gcc uClibc)
+$(curdir)/builddirs-compile:=. $(filter-out kernel-headers,$($(curdir)/builddirs))
+$(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)
# builddir dependencies
$(curdir)/uClibc/prepare:=$(curdir)/kernel-headers/prepare