aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-01-18 03:08:09 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-01-18 03:08:09 +0000
commit5b7668ca44e6d6e2bcf175e7f64093bd1b71db19 (patch)
tree23e57437ccb4c4e0b33797263116e22680f5960b /toolchain/Makefile
parent7a563f122fd80c56d4c2ef645493a33dec10baa3 (diff)
downloadupstream-5b7668ca44e6d6e2bcf175e7f64093bd1b71db19.tar.gz
upstream-5b7668ca44e6d6e2bcf175e7f64093bd1b71db19.tar.bz2
upstream-5b7668ca44e6d6e2bcf175e7f64093bd1b71db19.zip
use ext-toolchain.sh to integrate external toolchains Use ext-toolchain.sh to wrap external toolchain commands, abort build if certain features such as CONFIG_SOFT_FLOAT or CONFIG_IPV6 are enabled but not supported by the toolchain.
SVN-Revision: 29766
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 0443924c53..3a9cd0b2f8 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -28,7 +28,7 @@
curdir:=toolchain
# subdirectories to descend into
-$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),,kernel-headers binutils gcc/minimal gcc/initial gcc/final $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/minimal gcc/initial gcc/final $(LIBC) $(if $(CONFIG_GLIBC_PORTS),glibc-ports))
$(curdir)/builddirs-compile:=$($(curdir)/builddirs-prepare)
$(curdir)/builddirs-install:=$($(curdir)/builddirs-compile)