aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-06-23 14:38:03 +0000
committerSteven Barth <cyrus@openwrt.org>2015-06-23 14:38:03 +0000
commit2738526a16f9ebd100ac7a35d55b13e91e45e888 (patch)
treee63e9fe54643978c4bd5a3030e6d4fd59948099f /toolchain/Makefile
parent2086f7284c63d759071729108e35687c4679b9fc (diff)
downloadupstream-2738526a16f9ebd100ac7a35d55b13e91e45e888.tar.gz
upstream-2738526a16f9ebd100ac7a35d55b13e91e45e888.tar.bz2
upstream-2738526a16f9ebd100ac7a35d55b13e91e45e888.zip
toolchain: add fortify-headers, enable FORTIFY_SOURCE by default
Signed-off-by: Steven Barth <steven@midlink.org> SVN-Revision: 46117
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index c250cba480..cd5399e041 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -28,7 +28,7 @@
curdir:=toolchain
# subdirectories to descend into
-$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/minimal gcc/initial gcc/final $(LIBC)/headers $(LIBC))
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_INSIGHT),insight) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/minimal gcc/initial gcc/final $(LIBC)/headers $(LIBC) fortify-headers)
ifdef CONFIG_USE_UCLIBC
$(curdir)/builddirs += $(LIBC)/utils
endif