aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-10-10 19:25:48 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-10-10 19:25:48 +0000
commit215ccb66e6abdaed0a41582d6b8c40ffa340eea7 (patch)
treee8ecd7ecc708bda6515831abaffbcb8d9ee65d5f /toolchain/Makefile
parentb49cdabd4ae2c0239dc12eda5e1b7a21b9c2e5dc (diff)
downloadupstream-215ccb66e6abdaed0a41582d6b8c40ffa340eea7.tar.gz
upstream-215ccb66e6abdaed0a41582d6b8c40ffa340eea7.tar.bz2
upstream-215ccb66e6abdaed0a41582d6b8c40ffa340eea7.zip
gcc: add llvm-gcc and llvm from trunk (does not successfully compile a target yet, but gets close)
SVN-Revision: 18019
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 161b139d74..fa417879a7 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -46,6 +46,11 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
endif
endif
+ifdef CONFIG_GCC_VERSION_LLVM
+ $(curdir)/builddirs += llvm
+ $(curdir)/gcc/prepare += $(curdir)/llvm/install
+endif
+
ifneq ($(ARCH),)
$(TOOLCHAIN_DIR)/info.mk: .config
@for dir in $(TOOLCHAIN_DIR); do ( \