aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2018-06-28 19:28:02 -0400
committerTed Hess <thess@kitschensync.net>2018-07-05 10:17:06 -0400
commit0f543883cd0505a98fdc680ce2f08cbfca6d52a7 (patch)
treef4a6998faf88e47bee44aba46c1d72eb6c81d4ea /toolchain/Makefile
parent9009efa18b45b4b573111fafa777f7b642486e3e (diff)
downloadupstream-0f543883cd0505a98fdc680ce2f08cbfca6d52a7.tar.gz
upstream-0f543883cd0505a98fdc680ce2f08cbfca6d52a7.tar.bz2
upstream-0f543883cd0505a98fdc680ce2f08cbfca6d52a7.zip
toolchain: Replace YASM with NASM
Packages libx264 and ffmpeg are built with ASM options on x86 platforms. The current libx264 version no longer builds with YASM and requires NASM. ffmpeg 3.x can be built with either YASM or NASM however, furture 4.x versions will require NASM. Signed-off-by: Ted Hess <thess@kitschensync.net> Acked-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 409955c23a..9432990f4f 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -29,7 +29,7 @@
curdir:=toolchain
# subdirectories to descend into
-$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_YASM),yasm)
+$(curdir)/builddirs := $(if $(CONFIG_GDB),gdb) $(if $(CONFIG_EXTERNAL_TOOLCHAIN),wrapper,kernel-headers binutils gcc/initial gcc/final $(LIBC) fortify-headers) $(if $(CONFIG_NASM),nasm)
ifdef CONFIG_USE_UCLIBC
$(curdir)/builddirs += $(LIBC)/utils
endif