aboutsummaryrefslogtreecommitdiffstats
path: root/toolchain/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-09-01 17:51:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-09-01 17:51:36 +0000
commit00d1e599d753602c18f34d9642574d70b97e607d (patch)
tree8e81bd68be8fbbb35642d243211ede63a864ee10 /toolchain/Makefile
parentea70b60a072edab2da2ae77e91c21f233c548eff (diff)
downloadupstream-00d1e599d753602c18f34d9642574d70b97e607d.tar.gz
upstream-00d1e599d753602c18f34d9642574d70b97e607d.tar.bz2
upstream-00d1e599d753602c18f34d9642574d70b97e607d.zip
add a command for printing a cleaned up make target database - will be used to analyze package dependencies at some point
SVN-Revision: 22871
Diffstat (limited to 'toolchain/Makefile')
-rw-r--r--toolchain/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/Makefile b/toolchain/Makefile
index 3d8ba4c4ba..7c96c85e29 100644
--- a/toolchain/Makefile
+++ b/toolchain/Makefile
@@ -51,6 +51,7 @@ ifdef CONFIG_GCC_VERSION_LLVM
$(curdir)/gcc/minimal/compile += $(curdir)/llvm/install
endif
+ifndef DUMP_TARGET_DB
ifneq ($(ARCH),)
$(TOOLCHAIN_DIR)/info.mk: .config
@for dir in $(TOOLCHAIN_DIR); do ( \
@@ -62,6 +63,7 @@ ifneq ($(ARCH),)
@grep GCC_VERSION $@ >/dev/null 2>&1 || $(INSTALL_DATA) $(TOPDIR)/toolchain/info.mk $@
@touch $@
endif
+endif
# prerequisites for the individual targets
$(curdir)/ := .config prereq
@@ -69,7 +71,9 @@ $(curdir)//prepare = $(STAGING_DIR)/.prepared $(TOOLCHAIN_DIR)/info.mk
$(curdir)//compile = $(1)/prepare
$(curdir)//install = $(1)/compile
+ifndef DUMP_TARGET_DB
$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed:
+endif
$(eval $(call stampfile,$(curdir),toolchain,install,$(TOOLCHAIN_DIR)/stamp/.gcc-initial_installed,,$(TOOLCHAIN_DIR)))
$(eval $(call subdir,$(curdir)))