aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2016-12-14 17:10:52 +0100
committerJo-Philipp Wich <jo@mein.io>2016-12-14 18:39:14 +0100
commitfc6ed9521dca405da0a4f93bec504fd497ccf1fe (patch)
tree00ae3ec25bbfb4f7a61080bb72a91a990cb303b6 /target
parentb4aa3c899cbf1f81cd8a1ea197481ac84a9d646e (diff)
downloadupstream-fc6ed9521dca405da0a4f93bec504fd497ccf1fe.tar.gz
upstream-fc6ed9521dca405da0a4f93bec504fd497ccf1fe.tar.bz2
upstream-fc6ed9521dca405da0a4f93bec504fd497ccf1fe.zip
brcm63xx: image: trim revision code used for --rsa-signature
The imagetag RSA signature field may not exceed 20 characters, so trim the Git hash portion from the REVISION variable in order to ensure that the resulting string fits within this field. The current revision values may be longer than 20 chars, especially when building within a dirty tree. In this case, the revision will look like "r2435+75-b4aa3c8" which, combined with the "LEDE-" prefix, is 21 chars long. Fixes the following error spotted by the buildbots: Error: RSA Signature (rsa_signature,r) too long. make[4]: *** [.../lede-brcm63xx-generic-NEUFBOX6-squashfs-cfe.bin] Error 1 Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/image/bcm63xx.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/brcm63xx/image/bcm63xx.mk b/target/linux/brcm63xx/image/bcm63xx.mk
index 34d496e928..ce03f7b700 100644
--- a/target/linux/brcm63xx/image/bcm63xx.mk
+++ b/target/linux/brcm63xx/image/bcm63xx.mk
@@ -922,7 +922,7 @@ define Device/NEUFBOX4-SER
DEVICE_DTS := nb4-ser-r0
CFE_BOARD_ID := 96358VW
CFE_CHIP_ID := 6358
- CFE_EXTRAS += --rsa-signature "LEDE-$(REVISION)"
+ CFE_EXTRAS += --rsa-signature "LEDE-$(firstword $(subst -,$(space),$(REVISION)))"
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB2_PACKAGES)
endef
@@ -934,7 +934,7 @@ define Device/NEUFBOX4-FXC
DEVICE_DTS := nb4-fxc-r1
CFE_BOARD_ID := 96358VW
CFE_CHIP_ID := 6358
- CFE_EXTRAS += --rsa-signature "LEDE-$(REVISION)"
+ CFE_EXTRAS += --rsa-signature "LEDE-$(firstword $(subst -,$(space),$(REVISION)))"
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB2_PACKAGES)
endef
@@ -946,7 +946,7 @@ define Device/NEUFBOX6
DEVICE_DTS := nb6-ser-r0
CFE_BOARD_ID := NB6-SER-r0
CFE_CHIP_ID := 6362
- CFE_EXTRAS += --rsa-signature "LEDE-$(REVISION)"
+ CFE_EXTRAS += --rsa-signature "LEDE-$(firstword $(subst -,$(space),$(REVISION)))"
DEVICE_PACKAGES := \
$(B43_PACKAGES) $(USB2_PACKAGES)
endef