aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorThomas Roberts <tom.p.roberts@gmail.com>2017-02-13 17:29:34 +0000
committerJohn Crispin <john@phrozen.org>2017-02-20 09:10:17 +0100
commitf9278337cf4b9c699a41dfc1e4c448213be53e61 (patch)
treeb19f276ce789c6c08784846ee3765d801548b84f /target
parent7c9f5c7e6b43650315603db1fe03c1c2fb857135 (diff)
downloadupstream-f9278337cf4b9c699a41dfc1e4c448213be53e61.tar.gz
upstream-f9278337cf4b9c699a41dfc1e4c448213be53e61.tar.bz2
upstream-f9278337cf4b9c699a41dfc1e4c448213be53e61.zip
ar71xx: add support for TL-WR802N Version 2
This patch adds support for the TP-Link TL-WR802N Version 2. Specification: - SoC: Qualcomm Atheros QCA9533 (560 MHz, MIPS 24Kc) - RAM: 32 MiB - Storage: 4 MiB of FLash on board - Wireless: Built into QCA9533 (Honey Bee), PHY modes b/g/n - Ethernet: 1x100M (port0) Installation through OEM Web Interface: - Connect to TL-WR802N by Ethernet or Wi-Fi - Go to http://192.168.0.1 (default user is "admin" & password is "admin) - Go to "System Tools -> Firmware Upgrade" - Browse for firmware "*.factory-us.bin" or "*.factory-eu.bin" for eu model - Click upgrade Installation through tftp: Note: T_OUT, T_IN and GND on the board must be connected to USB TTL Serial Configuration 115200 8n1 - Boot the TL-WR802N - When "Autobooting in 1 seconds" appears type "tpl" followed by enter - Connect to the board Ethernet port (IPADDR: 192.168.1.1, ServerIP: 192.168.1.10) - tftpboot 0x80000000 <Firmware Image Name> - Record the result of "printenv bootcmd" - Enter "erase <Result of 'printenv bootcmd'> +0x3c0000" (e.g erase 0x9f020000 +0x3c0000) - Enter "cp.b 0x80000000 <Result of 'printenv bootcmd'> 0x3c0000" (e.g cp.b 0x80000000 0x9f020000 0x3c0000) - Enter "bootm <Result of 'printenv bootcmd'>" (e.g bootm 0x9f020000) Signed-off-by: Thomas Roberts <tom.p.roberts@gmail.com>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh1
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh7
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt8
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr802n-v2.c97
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/image/tp-link.mk16
-rw-r--r--target/linux/ar71xx/mikrotik/config-default1
12 files changed, 136 insertions, 2 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 70f5dac944..4dc4bfd51d 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -667,6 +667,9 @@ tl-wpa8630)
tl-wr802n-v1)
ucidef_set_led_wlan "wlan" "WLAN" "tp-link:blue:system" "phy0tpt"
;;
+tl-wr802n-v2)
+ ucidef_set_led_wlan "wlan" "WLAN" "$board:green:system" "phy0tpt"
+ ;;
tl-wr940n-v4|\
tl-wr941nd-v6)
ucidef_set_led_netdev "wan" "WAN" "tp-link:blue:wan" "eth0"
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index 3ae35f1a81..95faea0702 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -116,6 +116,7 @@ ar71xx_setup_interfaces()
tl-wa901nd-v4|\
tl-wr703n|\
tl-wr802n-v1|\
+ tl-wr802n-v2|\
tube2h|\
unifiac-lite|\
wndap360|\
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index ae6c693da8..106464105a 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -26,6 +26,7 @@ get_status_led() {
minibox-v1|\
som9331|\
sr3200|\
+ tl-wr802n-v2|\
xd3200)
status_led="$board:green:system"
;;
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 2ae4e1168f..ae0189d05b 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -220,6 +220,10 @@ tplink_board_detect() {
;;
"080200"*)
model="TP-Link TL-WR802N"
+
+ if [ "$hwid" = '08020002' -a "$mid" = '00000002' ]; then
+ hwver=' v2'
+ fi
;;
"083000"*)
model="TP-Link TL-WA830RE"
@@ -1031,6 +1035,9 @@ ar71xx_board_detect() {
*"TL-WR802N v1")
name="tl-wr802n-v1"
;;
+ *"TL-WR802N v2")
+ name="tl-wr802n-v2"
+ ;;
*TL-WA901ND)
name="tl-wa901nd"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index c2585b45a5..0175f6d32c 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -430,6 +430,7 @@ platform_check_image() {
tl-wr741nd-v4|\
tl-wr741nd|\
tl-wr802n-v1|\
+ tl-wr802n-v2|\
tl-wr810n|\
tl-wr841n-v11|\
tl-wr841n-v1|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index d45c3c46d2..0e2d786551 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -193,6 +193,7 @@ CONFIG_ATH79_MACH_TL_WR720N_V3=y
CONFIG_ATH79_MACH_TL_WR741ND=y
CONFIG_ATH79_MACH_TL_WR741ND_V4=y
CONFIG_ATH79_MACH_TL_WR802N_V1=y
+CONFIG_ATH79_MACH_TL_WR802N_V2=y
CONFIG_ATH79_MACH_TL_WR810N=y
CONFIG_ATH79_MACH_TL_WR841N_V1=y
CONFIG_ATH79_MACH_TL_WR841N_V8=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 44f754c2bc..514d05d6de 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -1533,6 +1533,14 @@ config ATH79_MACH_TL_WR802N_V1
select ATH79_DEV_LEDS_GPIO
select ATH79_DEV_M25P80
+config ATH79_MACH_TL_WR802N_V2
+ bool "TP-LINK TL-WR802N v2 support"
+ select SOC_QCA953X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+
config ATH79_MACH_TL_WR810N
bool "TP-LINK TL-WR810N support"
select SOC_QCA953X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index f402463dfc..64752591d5 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -198,6 +198,7 @@ obj-$(CONFIG_ATH79_MACH_TL_WR720N_V3) += mach-tl-wr720n-v3.o
obj-$(CONFIG_ATH79_MACH_TL_WR741ND) += mach-tl-wr741nd.o
obj-$(CONFIG_ATH79_MACH_TL_WR741ND_V4) += mach-tl-wr741nd-v4.o
obj-$(CONFIG_ATH79_MACH_TL_WR802N_V1) += mach-tl-wr802n.o
+obj-$(CONFIG_ATH79_MACH_TL_WR802N_V2) += mach-tl-wr802n-v2.o
obj-$(CONFIG_ATH79_MACH_TL_WR810N) += mach-tl-wr810n.o
obj-$(CONFIG_ATH79_MACH_TL_WR841N_V1) += mach-tl-wr841n.o
obj-$(CONFIG_ATH79_MACH_TL_WR841N_V8) += mach-tl-wr841n-v8.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr802n-v2.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr802n-v2.c
new file mode 100644
index 0000000000..10e0c595a6
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr802n-v2.c
@@ -0,0 +1,97 @@
+/*
+ * TP-LINK TL-WR802N v2
+ *
+ * Copyright (C) 2016 Thomas Roberts <tom.p.roberts@gmail.com <mailto:tom.p.roberts@gmail.com>>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define TL_WR802N_V2_GPIO_LED_SYSTEM 13
+#define TL_WR802N_V2_GPIO_BTN_RESET 11
+
+#define TL_WR802N_V2_KEYS_POLL_INTERVAL 20 /* msecs */
+#define TL_WR802N_V2_KEYS_DEBOUNCE_INTERVAL (3 * TL_WR802N_V2_KEYS_POLL_INTERVAL)
+
+static const char *tl_wr802n_v2_part_probes[] = {
+ "tp-link",
+ NULL,
+};
+
+static struct flash_platform_data tl_wr802n_v2_flash_data = {
+ .part_probes = tl_wr802n_v2_part_probes,
+};
+
+static struct gpio_led tl_wr802n_v2_leds_gpio[] __initdata = {
+ {
+ .name = "tl-wr802n-v2:green:system",
+ .gpio = TL_WR802N_V2_GPIO_LED_SYSTEM,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button tl_wr802n_v2_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = TL_WR802N_V2_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = TL_WR802N_V2_GPIO_BTN_RESET,
+ .active_low = 0,
+ }
+};
+
+static void __init tl_ap143_setup(void)
+{
+ u8 *mac = (u8 *) KSEG1ADDR(0x1f01fc00);
+ u8 *ee = (u8 *) KSEG1ADDR(0x1fff1000);
+ u8 tmpmac[ETH_ALEN];
+
+ ath79_register_m25p80(&tl_wr802n_v2_flash_data);
+
+ ath79_setup_ar933x_phy4_switch(false, false);
+
+ ath79_register_mdio(0, 0x0);
+
+ /* LAN */
+ ath79_switch_data.phy4_mii_en = 1;
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+ ath79_eth0_data.duplex = DUPLEX_FULL;
+ ath79_eth0_data.speed = SPEED_100;
+ ath79_eth0_data.phy_mask = BIT(4);
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 1);
+ ath79_register_eth(0);
+
+ ath79_init_mac(tmpmac, mac, 0);
+ ath79_register_wmac(ee, tmpmac);
+};
+
+static void __init tl_wr802n_v2_setup(void)
+{
+ tl_ap143_setup();
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(tl_wr802n_v2_leds_gpio),
+ tl_wr802n_v2_leds_gpio);
+
+ ath79_register_gpio_keys_polled(1, TL_WR802N_V2_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(tl_wr802n_v2_gpio_keys),
+ tl_wr802n_v2_gpio_keys);
+}
+
+MIPS_MACHINE(ATH79_MACH_TL_WR802N_V2, "TL-WR802N-v2", "TP-LINK TL-WR802N v2",
+ tl_wr802n_v2_setup); \ No newline at end of file
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 39a80fc6fb..4cad6287a8 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -237,6 +237,7 @@ enum ath79_mach_type {
ATH79_MACH_TL_WR741ND, /* TP-LINK TL-WR741ND */
ATH79_MACH_TL_WR741ND_V4, /* TP-LINK TL-WR741ND v4 */
ATH79_MACH_TL_WR802N_V1, /* TP-LINK TL-WR802N v1 */
+ ATH79_MACH_TL_WR802N_V2, /* TP-LINK TL-WR802N v2 */
ATH79_MACH_TL_WR810N, /* TP-LINK TL-WR810N */
ATH79_MACH_TL_WR841N_V1, /* TP-LINK TL-WR841N v1 */
ATH79_MACH_TL_WR841N_V11, /* TP-LINK TL-WR841N/ND v11 */
diff --git a/target/linux/ar71xx/image/tp-link.mk b/target/linux/ar71xx/image/tp-link.mk
index 34b5390fca..b251135c55 100644
--- a/target/linux/ar71xx/image/tp-link.mk
+++ b/target/linux/ar71xx/image/tp-link.mk
@@ -631,12 +631,24 @@ TARGET_DEVICES += tl-wr740n-v1 tl-wr740n-v3 tl-wr740n-v4 tl-wr740n-v5 tl-wr740n-
define Device/tl-wr802n-v1
$(Device/tplink-4mlzma)
DEVICE_TITLE := TP-LINK TL-WR802N v1
- BOARDNAME := TL-WR802N-v1
+ BOARDNAME := TL-WR802N-v1
DEVICE_PROFILE := TLWR802
TPLINK_HWID := 0x08020001
TPLINK_HWREV := 1
endef
-TARGET_DEVICES += tl-wr802n-v1
+
+define Device/tl-wr802n-v2
+ $(Device/tplink-4mlzma)
+ DEVICE_TITLE := TP-LINK TL-WR802N v2
+ BOARDNAME := TL-WR802N-v2
+ DEVICE_PROFILE := TLWR802
+ TPLINK_HWID := 0x08020002
+ TPLINK_HWREV := 2
+ IMAGES += factory-us.bin factory-eu.bin
+ IMAGE/factory-us.bin := append-rootfs | mktplinkfw factory -C US
+ IMAGE/factory-eu.bin := append-rootfs | mktplinkfw factory -C EU
+endef
+TARGET_DEVICES += tl-wr802n-v1 tl-wr802n-v2
define Device/tl-wr841-v1.5
$(Device/tplink-4m)
diff --git a/target/linux/ar71xx/mikrotik/config-default b/target/linux/ar71xx/mikrotik/config-default
index aa2cf3c261..733914983e 100644
--- a/target/linux/ar71xx/mikrotik/config-default
+++ b/target/linux/ar71xx/mikrotik/config-default
@@ -158,6 +158,7 @@ CONFIG_ATH79_MACH_RBSXTLITE=y
# CONFIG_ATH79_MACH_TL_WR741ND is not set
# CONFIG_ATH79_MACH_TL_WR741ND_V4 is not set
# CONFIG_ATH79_MACH_TL_WR802N_V1 is not set
+# CONFIG_ATH79_MACH_TL_WR802N_V2 is not set
# CONFIG_ATH79_MACH_TL_WR810N is not set
# CONFIG_ATH79_MACH_TL_WR841N_V1 is not set
# CONFIG_ATH79_MACH_TL_WR841N_V8 is not set