aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-11-22 19:49:40 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-11-22 19:49:40 +0000
commitf37275bddaf66f75e58dff389123fb1f01e8e0d5 (patch)
treea2e1d191d01ba8d1112c5dabf1fc87b3975390f4 /target
parentee2c64a6487191b5f1248580c557328adc39ddd8 (diff)
downloadupstream-f37275bddaf66f75e58dff389123fb1f01e8e0d5.tar.gz
upstream-f37275bddaf66f75e58dff389123fb1f01e8e0d5.tar.bz2
upstream-f37275bddaf66f75e58dff389123fb1f01e8e0d5.zip
AA: imagebuilder: merge r34301
git-svn-id: svn://svn.openwrt.org/openwrt/branches/attitude_adjustment@34302 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/imagebuilder/files/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index b0d0698acd..4d0f1fe115 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -134,6 +134,14 @@ package_install: FORCE
copy_files: FORCE
@echo
@echo Copying extra files
+ @( cd $(USER_FILES); find -type f ) | \
+ ( cd $(TARGET_DIR); while :; do \
+ read FILE; \
+ [ -z "$$FILE" ] && break; \
+ [ -L "$$FILE" ] || continue; \
+ echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
+ rm -f "$$FILE"; \
+ done; )
$(CP) $(USER_FILES)/* $(TARGET_DIR)/
package_postinst: FORCE