aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorConor O'Gorman <i@conorogorman.net>2017-01-15 22:01:03 +0000
committerJohn Crispin <john@phrozen.org>2017-01-20 00:40:27 +0100
commiteb97f41fc23ffbd6635b402d6e0bbd8e8ef029bb (patch)
tree34642053bba77125bc7bdb8224c7fe279a07f2e1 /target
parent07a02efd07ad7b13aae6d58d55a53fcecbe691d5 (diff)
downloadupstream-eb97f41fc23ffbd6635b402d6e0bbd8e8ef029bb.tar.gz
upstream-eb97f41fc23ffbd6635b402d6e0bbd8e8ef029bb.tar.bz2
upstream-eb97f41fc23ffbd6635b402d6e0bbd8e8ef029bb.zip
ar71xx: add Abicom SC300M support
Support Abicom International Scorpion SC300M Module QCA9550 700MHz Extended Temperature Range 256MB DDR2 256MB Nand Flash 16MB SPI Flash 802.11a/na/b/g/ng GPIO x 22, USB x2, PCIe x2 10/100/1000 Ethernet 23dBm, Optional Onboard Antenna DC Input, 8-20V DC 85 x 55 mm Signed-off-by: Conor O'Gorman <i@conorogorman.net>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds1
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt11
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-sc300m.c132
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/image/generic.mk10
11 files changed, 164 insertions, 1 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 84cfb1e616..57925c5aae 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -282,6 +282,7 @@ gl-mifi)
esac
;;
gl-domino|\
+sc300m|\
wrt160nl)
ucidef_set_led_wlan "wlan" "WLAN" "$board:blue:wlan" "phy0tpt"
;;
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index c916462fc6..987a8e4f12 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -94,6 +94,7 @@ ar71xx_setup_interfaces()
rb-sxt5n|\
re450|\
rocket-m-xw|\
+ sc300m |\
tl-mr10u|\
tl-mr11u|\
tl-mr12u|\
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 75c6c9acba..551088b060 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -295,7 +295,8 @@ get_status_led() {
rb-sxt5n)
status_led="rb:green:power"
;;
- re450)
+ re450|\
+ sc300m)
status_led="$board:blue:power"
;;
routerstation|\
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 7f27f45635..fb8997fe89 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -884,6 +884,9 @@ ar71xx_board_detect() {
*RW2458N)
name="rw2458n"
;;
+ *SC300M)
+ name="sc300m"
+ ;;
*"SMART-300")
name="smart-300"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 80da9131c7..d98f2733f5 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -254,6 +254,7 @@ platform_check_image() {
rocket-m-xw|\
rocket-m|\
rw2458n|\
+ sc300m|\
sr3200|\
tew-632brp|\
tew-712br|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index a79d53e556..dc5ed1eb57 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -148,6 +148,7 @@ CONFIG_ATH79_MACH_R6100=y
# CONFIG_ATH79_MACH_RBSXTLITE is not set
CONFIG_ATH79_MACH_RE450=y
CONFIG_ATH79_MACH_RW2458N=y
+CONFIG_ATH79_MACH_SC300M=y
CONFIG_ATH79_MACH_SMART_300=y
CONFIG_ATH79_MACH_SOM9331=y
CONFIG_ATH79_MACH_SR3200=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index b38c30ae37..8514ff94bf 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -42,6 +42,17 @@ config ATH79_MACH_TUBE2H
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+config ATH79_MACH_SC300M
+ bool "Abicom SC300M board support"
+ select SOC_QCA955X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_USB
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_ALL0258N
bool "Allnet ALL0258N support"
select SOC_AR724X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 03bbe218d7..973f4ef0a7 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -152,6 +152,7 @@ obj-$(CONFIG_ATH79_MACH_RB95X) += mach-rb95x.o
obj-$(CONFIG_ATH79_MACH_RBSXTLITE) += mach-rbsxtlite.o
obj-$(CONFIG_ATH79_MACH_RE450) += mach-re450.o
obj-$(CONFIG_ATH79_MACH_RW2458N) += mach-rw2458n.o
+obj-$(CONFIG_ATH79_MACH_SC300M) += mach-sc300m.o
obj-$(CONFIG_ATH79_MACH_SMART_300) += mach-smart-300.o
obj-$(CONFIG_ATH79_MACH_SOM9331) += mach-som9331.o
obj-$(CONFIG_ATH79_MACH_SR3200) += mach-sr3200.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-sc300m.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-sc300m.c
new file mode 100644
index 0000000000..2830bcf276
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-sc300m.c
@@ -0,0 +1,132 @@
+/*
+ * Abicom International Scorpion SC300M Module support.
+ *
+ * Copyright (c) 2012 Qualcomm Atheros
+ * Copyright (c) 2012-2013 Gabor Juhos <juhosg@openwrt.org>
+ * Copyright (c) 2017 Conor O'Gorman <i@conorogorman.net>
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include <linux/platform_device.h>
+#include <linux/platform_data/phy-at803x.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "pci.h"
+#include "dev-ap9x-pci.h"
+#include "dev-gpio-buttons.h"
+#include "dev-eth.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-nfc.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define SC300M_GPIO_LED_WLAN 0
+#define SC300M_GPIO_LED_POWER 1
+
+#define SC300M_GPIO_BTN_RESET 17
+
+#define SC300M_KEYS_POLL_INTERVAL 20 /* msecs */
+#define SC300M_KEYS_DEBOUNCE_INTERVAL (3 * SC300M_KEYS_POLL_INTERVAL)
+
+#define SC300M_MAC0_OFFSET 0
+#define SC300M_MAC1_OFFSET 6
+#define SC300M_WMAC_CALDATA_OFFSET 0x1000
+#define SC300M_PCIE_CALDATA_OFFSET 0x5000
+
+static struct gpio_led sc300m_leds_gpio[] __initdata = {
+ {
+ .name = "sc300m:blue:wlan",
+ .gpio = SC300M_GPIO_LED_WLAN,
+ .active_low = 1,
+ },
+ {
+ .name = "sc300m:blue:power",
+ .gpio = SC300M_GPIO_LED_POWER,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_keys_button sc300m_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = SC300M_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = SC300M_GPIO_BTN_RESET,
+ .active_low = 1,
+ }
+};
+
+static struct at803x_platform_data at803x_data = {
+ .disable_smarteee = 1,
+ .enable_rgmii_rx_delay = 0,
+ .enable_rgmii_tx_delay = 0,
+};
+
+static struct mdio_board_info sc300m_mdio0_info[] = {
+ {
+ .bus_id = "ag71xx-mdio.0",
+ .phy_addr = 1,
+ .platform_data = &at803x_data,
+ },
+};
+
+static void __init sc300m_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(sc300m_leds_gpio),
+ sc300m_leds_gpio);
+ ath79_register_gpio_keys_polled(-1, SC300M_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(sc300m_gpio_keys),
+ sc300m_gpio_keys);
+
+ ath79_register_usb();
+ ath79_register_nfc();
+
+ ath79_register_wmac(art + SC300M_WMAC_CALDATA_OFFSET, NULL);
+
+ ath79_register_mdio(0, 0);
+ mdiobus_register_board_info(sc300m_mdio0_info,
+ ARRAY_SIZE(sc300m_mdio0_info));
+
+ ath79_init_mac(ath79_eth0_data.mac_addr, art + SC300M_MAC0_OFFSET, 0);
+
+ ath79_eth0_pll_data.pll_1000 = 0xa6000101;
+ ath79_eth0_pll_data.pll_100 = 0xa4000101;
+ /* GMAC0 is connected to the RMGII interface */
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+ ath79_eth0_data.phy_mask = 0xF;
+ ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+
+ ath79_register_eth(0);
+
+ /* GMAC1 is connected to the SGMII interface */
+ ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_SGMII;
+ ath79_eth1_data.speed = SPEED_1000;
+ ath79_eth1_data.duplex = DUPLEX_FULL;
+
+ ath79_register_eth(1);
+
+ ath79_register_pci();
+}
+
+MIPS_MACHINE(ATH79_MACH_SC300M, "SC300M", "Abicom SC300M", sc300m_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index f9e8422faa..93bb5947d3 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -169,6 +169,7 @@ enum ath79_mach_type {
ATH79_MACH_RB_SXTLITE5ND, /* Mikrotik RouterBOARD SXT Lite 5nD */
ATH79_MACH_RE450, /* TP-LINK RE450 */
ATH79_MACH_RW2458N, /* Redwave RW2458N */
+ ATH79_MACH_SC300M, /* Abicom SC300M */
ATH79_MACH_SMART_300, /* NC-LINK SMART-300 */
ATH79_MACH_SOM9331, /* OpenEmbed SOM9331 */
ATH79_MACH_SR3200, /* YunCore SR3200 */
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index e2867e6c40..f8445b5193 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -464,6 +464,16 @@ define Device/onion-omega
endef
TARGET_DEVICES += onion-omega
+define Device/sc300m
+ DEVICE_TITLE := Abicom SC300M
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+ BOARDNAME = SC300M
+ IMAGE_SIZE = 15744k
+ CONSOLE = ttyS0,115200
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),15744k(firmware),128k(APConfig),128k(kplog),64k(ART)
+endef
+TARGET_DEVICES += sc300m
+
define Device/smart-300
$(Device/tplink-8mlzma)
DEVICE_TITLE := NC-LINK SMART-300