aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2020-10-22 13:29:57 +0200
committerPetr Štetiar <ynezz@true.cz>2020-12-11 13:56:29 +0100
commite401a2a42e6d7c892e1cf7d765fa5ec9b2db3fb3 (patch)
tree0ab5f979da9b976876f1ce28b8b43db859c97692 /target
parent52aa2017d32226284c586f0142cafeba32ce7528 (diff)
downloadupstream-e401a2a42e6d7c892e1cf7d765fa5ec9b2db3fb3.tar.gz
upstream-e401a2a42e6d7c892e1cf7d765fa5ec9b2db3fb3.tar.bz2
upstream-e401a2a42e6d7c892e1cf7d765fa5ec9b2db3fb3.zip
mvebu: fix initramfs/kernel image for CZNIC Turris Omnia
This adds DTB to kernel and that way makes it possible to easily boot initramfs image and also kernel. The sequence to boot initramfs on Omnia is then just: env set bootargs earlyprintk console=ttyS0,115200 dhcp 0x1000000 192.168.1.1:openwrt-mvebu-cortexa9-cznic_turris-omnia-initramfs-kernel.bin bootz 0x1000000 Without this change kernel boot won't proceed and is stuck on "Starting kernel". Signed-off-by: Karel Kočí <karel.koci@nic.cz> [fixed From: to match with SoB:] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target')
-rw-r--r--target/linux/mvebu/image/cortexa9.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/mvebu/image/cortexa9.mk b/target/linux/mvebu/image/cortexa9.mk
index ea20a25a29..67f68b1770 100644
--- a/target/linux/mvebu/image/cortexa9.mk
+++ b/target/linux/mvebu/image/cortexa9.mk
@@ -32,8 +32,7 @@ define Device/cznic_turris-omnia
DEVICE_VENDOR := CZ.NIC
DEVICE_MODEL := Turris Omnia
KERNEL_INSTALL := 1
- KERNEL := kernel-bin
- KERNEL_INITRAMFS := kernel-bin
+ KERNEL := kernel-bin | append-dtb
DEVICE_PACKAGES := \
mkf2fs e2fsprogs kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
wpad-basic-wolfssl kmod-ath9k kmod-ath10k-ct ath10k-firmware-qca988x-ct \