aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-27 19:38:11 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-27 19:38:11 +0000
commite2bd975a2a26e615a7c253f9a8296a0efe1e3349 (patch)
tree98abf08a046f0651cd20f7a5744cb3d5b80f022b /target
parentc7966a12b5b0a44e308b70b52fb81fcbf2ea6b44 (diff)
downloadupstream-e2bd975a2a26e615a7c253f9a8296a0efe1e3349.tar.gz
upstream-e2bd975a2a26e615a7c253f9a8296a0efe1e3349.tar.bz2
upstream-e2bd975a2a26e615a7c253f9a8296a0efe1e3349.zip
ar71xx: image: add MkuImage{Gzip,Lzma}/initramfs helpers
SVN-Revision: 31115
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index acfa831883..da4d1fde5c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -68,11 +68,21 @@ define MkuImageLzma
$(call MkuImage,lzma,,$(KDIR_TMP)/vmlinux-$(1).bin.lzma,$(KDIR_TMP)/vmlinux-$(1).uImage)
endef
+define MkuImageLzma/initramfs
+ $(call PatchKernelLzma,$(1),$(2))
+ $(call MkuImage,lzma,,$(KDIR_TMP)/vmlinux-$(1).bin.lzma,$(call imgname,initramfs,$(1))-uImage.bin)
+endef
+
define MkuImageGzip
$(call PatchKernelGzip,$(1),$(2))
$(call MkuImage,gzip,,$(KDIR_TMP)/vmlinux-$(1).bin.gz,$(KDIR_TMP)/vmlinux-$(1).uImage)
endef
+define MkuImageGzip/initramfs
+ $(call PatchKernelGzip,$(1),$(2))
+ $(call MkuImage,gzip,,$(KDIR_TMP)/vmlinux-$(1).bin.gz,$(call imgname,initramfs,$(1))-uImage.bin)
+endef
+
define MkuImageOKLI
$(call MkuImage,lzma,-M 0x4f4b4c49,$(KDIR)/vmlinux.bin.lzma,$(KDIR_TMP)/vmlinux-$(1).okli)
endef
@@ -232,8 +242,7 @@ define Image/Build/AthGzip
endef
define Image/Build/AthGzip/initramfs
- $(call MkuImageGzip,$(2),$(3) $(4))
- $(CP) $(KDIR_TMP)/vmlinux-$(2).uImage $(call imgname,$(1),$(2))-uImage.bin
+ $(call MkuImageGzip/initramfs,$(2),$(3) $(4))
endef
define Image/Build/AthLzma
@@ -242,8 +251,7 @@ define Image/Build/AthLzma
endef
define Image/Build/AthLzma/initramfs
- $(call MkuImageLzma,$(2),$(3) $(4))
- $(CP) $(KDIR_TMP)/vmlinux-$(2).uImage $(call imgname,$(1),$(2))-uImage.bin
+ $(call MkuImageLzma/initramfs,$(2),$(3) $(4))
endef
define Image/Build/PB4X