aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-09-07 13:28:07 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-09-07 13:28:07 +0000
commite15237af0ab7623a3a4f3ffc59e5578f115cf4ba (patch)
tree35bae2b9f024c6e74c357da68483e93c2a889f5c /target
parentb63a7c8640cab901370a644fa4709fb519d8acc9 (diff)
downloadupstream-e15237af0ab7623a3a4f3ffc59e5578f115cf4ba.tar.gz
upstream-e15237af0ab7623a3a4f3ffc59e5578f115cf4ba.tar.bz2
upstream-e15237af0ab7623a3a4f3ffc59e5578f115cf4ba.zip
build more image types
SVN-Revision: 12545
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 67764d647c..57eebb1958 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1,4 +1,4 @@
-#
+#
# Copyright (C) 2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@@ -7,12 +7,19 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+VMLINUX:=openwrt-$(BOARD)-vmlinux
+
+ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+ VMLINUX:=openwrt-$(BOARD)-vmlinux-initramfs
+endif
+
define Image/BuildKernel
- cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(VMLINUX).elf
+ cp $(KDIR)/vmlinux $(BIN_DIR)/$(VMLINUX).bin
gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
- dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma bs=65536 conv=sync
- dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.gz bs=65536 conv=sync
+ dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/$(VMLINUX).lzma bs=65536 conv=sync
+ dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/$(VMLINUX).gz bs=65536 conv=sync
$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.lzma
mkimage -A mips -O linux -T kernel -a 0x80060000 -C gzip -e \
0x80060000 \