aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorThomas Reifferscheid <thomas@reifferscheid.org>2017-02-21 17:02:49 +0100
committerMathias Kresin <dev@kresin.me>2017-02-21 21:18:33 +0100
commite01b034cdc64123baaca8d15f15b2b90e8a39db9 (patch)
treee3b71a9be250f0d075bf5c427f7bb0078a9db922 /target
parent0aa46bf76ab01fe1f64b0992fe2a8196c3b19d89 (diff)
downloadupstream-e01b034cdc64123baaca8d15f15b2b90e8a39db9.tar.gz
upstream-e01b034cdc64123baaca8d15f15b2b90e8a39db9.tar.bz2
upstream-e01b034cdc64123baaca8d15f15b2b90e8a39db9.zip
ipq806x: fix fakerootfs position
The fakeroot header is expected by the netgear bootloader in the last 64 bytes of the last block used by the uImage. With the current linux-4.9 uImage being more than 128k smaller than the linux-4.4 uImage the bootloader was unable to locate the rootfs ih_magic and was refusing to load and start the kernel. Fixes: FS#542 Signed-off-by: Thomas Reifferscheid <thomas@reifferscheid.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq806x/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ipq806x/image/Makefile b/target/linux/ipq806x/image/Makefile
index b00e197586..cec26c2142 100644
--- a/target/linux/ipq806x/image/Makefile
+++ b/target/linux/ipq806x/image/Makefile
@@ -58,8 +58,8 @@ define Device/DniImage
FILESYSTEMS := squashfs
KERNEL_SUFFIX := -uImage
KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
- KERNEL = kernel-bin | append-dtb | uImage none | pad-offset $$(KERNEL_SIZE) 64 | \
- append-uImage-fakeroot-hdr
+ KERNEL = kernel-bin | append-dtb | uImage none | pad-offset $$(BLOCKSIZE) 64 | append-uImage-fakeroot-hdr | \
+ pad-to $$(KERNEL_SIZE)
KERNEL_NAME := zImage
NETGEAR_BOARD_ID :=
NETGEAR_HW_ID :=