aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLars-Peter Clausen <lars@metafoo.de>2010-08-29 21:16:00 +0000
committerLars-Peter Clausen <lars@metafoo.de>2010-08-29 21:16:00 +0000
commitdc116b1887947d110a0158e1d201a7c1e139ef73 (patch)
tree6751f59b7899d719c0bc931bd7e4b719fc87d314 /target
parent429c8a56b6b9a1ada2d10d17488b29590232c579 (diff)
downloadupstream-dc116b1887947d110a0158e1d201a7c1e139ef73.tar.gz
upstream-dc116b1887947d110a0158e1d201a7c1e139ef73.tar.bz2
upstream-dc116b1887947d110a0158e1d201a7c1e139ef73.zip
Add different profiles for Sheevaplug and Dockstar
Thanks to Gerrit Visser SVN-Revision: 22838
Diffstat (limited to 'target')
-rw-r--r--target/linux/kirkwood/base-files-Dockstar/etc/config/network9
-rw-r--r--target/linux/kirkwood/base-files-Dockstar/etc/config/system16
-rw-r--r--target/linux/kirkwood/image/Makefile6
-rw-r--r--target/linux/kirkwood/profiles/100-Sheevaplug.mk17
-rw-r--r--target/linux/kirkwood/profiles/200-Dockstar.mk17
5 files changed, 62 insertions, 3 deletions
diff --git a/target/linux/kirkwood/base-files-Dockstar/etc/config/network b/target/linux/kirkwood/base-files-Dockstar/etc/config/network
new file mode 100644
index 0000000000..9fd44f1283
--- /dev/null
+++ b/target/linux/kirkwood/base-files-Dockstar/etc/config/network
@@ -0,0 +1,9 @@
+config 'interface' 'loopback'
+ option 'ifname' 'lo'
+ option 'proto' 'static'
+ option 'ipaddr' '127.0.0.1'
+ option 'netmask' '255.0.0.0'
+
+config 'interface' 'lan'
+ option 'ifname' 'eth0'
+ option 'proto' 'dhcp'
diff --git a/target/linux/kirkwood/base-files-Dockstar/etc/config/system b/target/linux/kirkwood/base-files-Dockstar/etc/config/system
new file mode 100644
index 0000000000..4de2b9f0bd
--- /dev/null
+++ b/target/linux/kirkwood/base-files-Dockstar/etc/config/system
@@ -0,0 +1,16 @@
+# system file for Dockstar
+config system
+ option hostname OpenWrt
+ option timezone UTC
+
+config rdate
+ option interface eth0
+config led
+ option 'sysfs' 'dockstar:green:health'
+ option 'trigger' 'none'
+ option 'default' '1'
+config led
+ option 'sysfs' 'dockstar:orange:misc'
+ option 'trigger' 'netdev'
+ option 'mode' 'tx rx'
+ option 'dev' 'eth0'
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 129ad95662..c93be67512 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -21,12 +21,12 @@ endef
define Image/Build
$(if $(Image/Build/$(1)), \
$(call Image/Build/$(1),$(1)), \
- $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
+ $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-$(1).img \
)
endef
define Image/Build/jffs2-128k
- dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-$(1).img \
bs=2048 conv=sync
endef
@@ -35,7 +35,7 @@ define Image/Build/squashfs
( \
dd if=$(KDIR)/uImage bs=4096k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
- ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-$(1).img
endef
$(eval $(call BuildImage))
diff --git a/target/linux/kirkwood/profiles/100-Sheevaplug.mk b/target/linux/kirkwood/profiles/100-Sheevaplug.mk
new file mode 100644
index 0000000000..65008fe66a
--- /dev/null
+++ b/target/linux/kirkwood/profiles/100-Sheevaplug.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Sheevaplug
+ NAME:=Globalscale Sheevaplug
+ PACKAGES:=
+endef
+
+define Profile/Sheevaplug/Description
+ Globalscale Sheevaplug Profile
+endef
+
+$(eval $(call Profile,Sheevaplug))
diff --git a/target/linux/kirkwood/profiles/200-Dockstar.mk b/target/linux/kirkwood/profiles/200-Dockstar.mk
new file mode 100644
index 0000000000..5b5d9cbdb6
--- /dev/null
+++ b/target/linux/kirkwood/profiles/200-Dockstar.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Dockstar
+ NAME:=Seagate Dockstar
+ PACKAGES:=
+endef
+
+define Profile/Dockstar/Description
+ Seagate Dockstar Profile
+endef
+
+$(eval $(call Profile,Dockstar))