aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2022-09-28 17:42:48 +0200
committerDavid Bauer <mail@david-bauer.net>2022-10-02 23:04:39 +0200
commitdb19efee951231b38573cffaadb15fad8f9c058d (patch)
tree31baec6cb9a32acb06801865f62d0b4bd9f9a9b7 /target
parent116feb4a1cadeeb15ec55b995d8a3fd3d2d9a959 (diff)
downloadupstream-db19efee951231b38573cffaadb15fad8f9c058d.tar.gz
upstream-db19efee951231b38573cffaadb15fad8f9c058d.tar.bz2
upstream-db19efee951231b38573cffaadb15fad8f9c058d.zip
ipq40xx: disable boards not converted to DSA
Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ipq40xx/image/chromium.mk3
-rw-r--r--target/linux/ipq40xx/image/generic.mk123
-rw-r--r--target/linux/ipq40xx/image/mikrotik.mk3
3 files changed, 86 insertions, 43 deletions
diff --git a/target/linux/ipq40xx/image/chromium.mk b/target/linux/ipq40xx/image/chromium.mk
index 2abd2df02a..7410794fb4 100644
--- a/target/linux/ipq40xx/image/chromium.mk
+++ b/target/linux/ipq40xx/image/chromium.mk
@@ -33,4 +33,5 @@ define Device/google_wifi
DEVICE_PACKAGES := partx-utils mkf2fs e2fsprogs \
kmod-fs-ext4 kmod-fs-f2fs kmod-google-firmware
endef
-TARGET_DEVICES += google_wifi
+# Missing DSA Setup
+#TARGET_DEVICES += google_wifi
diff --git a/target/linux/ipq40xx/image/generic.mk b/target/linux/ipq40xx/image/generic.mk
index 81cc83e28f..47e8c129b4 100644
--- a/target/linux/ipq40xx/image/generic.mk
+++ b/target/linux/ipq40xx/image/generic.mk
@@ -181,14 +181,16 @@ define Device/aruba_ap-303h
$(call Device/aruba_glenmorangie)
DEVICE_MODEL := AP-303H
endef
-TARGET_DEVICES += aruba_ap-303h
+# Missing DSA Setup
+#TARGET_DEVICES += aruba_ap-303h
define Device/aruba_ap-365
$(call Device/aruba_glenmorangie)
DEVICE_MODEL := AP-365
DEVICE_PACKAGES := kmod-hwmon-ad7418 ipq-wifi-aruba_ap-365
endef
-TARGET_DEVICES += aruba_ap-365
+# Missing DSA Setup
+#TARGET_DEVICES += aruba_ap-365
define Device/asus_map-ac2200
$(call Device/FitImageLzma)
@@ -226,7 +228,8 @@ define Device/asus_rt-ac42u
UIMAGE_NAME:=$(shell echo -e '\03\01\01\01RT-AC82U')
DEVICE_PACKAGES := ath10k-firmware-qca9984-ct kmod-usb-ledtrig-usbport
endef
-TARGET_DEVICES += asus_rt-ac42u
+# Missing DSA Setup
+#TARGET_DEVICES += asus_rt-ac42u
define Device/asus_rt-ac58u
$(call Device/FitImageLzma)
@@ -293,7 +296,8 @@ define Device/avm_fritzrepeater-3000
SOC := qcom-ipq4019
DEVICE_PACKAGES := ath10k-firmware-qca9984-ct fritz-caldata fritz-tffs-nand
endef
-TARGET_DEVICES += avm_fritzrepeater-3000
+# Missing DSA Setup
+#TARGET_DEVICES += avm_fritzrepeater-3000
define Device/buffalo_wtr-m2133hp
$(call Device/FitImage)
@@ -305,7 +309,8 @@ define Device/buffalo_wtr-m2133hp
BLOCKSIZE := 128k
PAGESIZE := 2048
endef
-TARGET_DEVICES += buffalo_wtr-m2133hp
+# Missing DSA Setup
+#TARGET_DEVICES += buffalo_wtr-m2133hp
define Device/cellc_rtl30vw
KERNEL_SUFFIX := -fit-zImage.itb
@@ -335,7 +340,8 @@ define Device/cilab_meshpoint-one
DEVICE_MODEL := MeshPoint.One
DEVICE_PACKAGES := kmod-i2c-gpio kmod-iio-bmp280-i2c kmod-hwmon-ina2xx kmod-rtc-pcf2127
endef
-TARGET_DEVICES += cilab_meshpoint-one
+# Missing DSA Setup
+#TARGET_DEVICES += cilab_meshpoint-one
define Device/compex_wpj419
$(call Device/FitImage)
@@ -349,7 +355,8 @@ define Device/compex_wpj419
PAGESIZE := 2048
FILESYSTEMS := squashfs
endef
-TARGET_DEVICES += compex_wpj419
+# Missing DSA Setup
+#TARGET_DEVICES += compex_wpj419
define Device/compex_wpj428
$(call Device/FitImage)
@@ -386,7 +393,8 @@ define Device/devolo_magic-2-wifi-next
DEVICE_PACKAGES := ipq-wifi-devolo_magic-2-wifi-next
DEFAULT := n
endef
-TARGET_DEVICES += devolo_magic-2-wifi-next
+# Missing DSA Setup
+#TARGET_DEVICES += devolo_magic-2-wifi-next
define Device/dlink_dap-2610
$(call Device/FitImageLzma)
@@ -412,7 +420,8 @@ define Device/dlink_dap-2610
IMAGE/factory.bin := append-kernel | pad-offset 6144k 160 | append-rootfs | wrgg-image | check-size
IMAGE/sysupgrade.bin := append-kernel | wrgg-image | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size | append-metadata
endef
-TARGET_DEVICES += dlink_dap-2610
+# Missing DSA Setup
+#TARGET_DEVICES += dlink_dap-2610
define Device/edgecore_ecw5211
$(call Device/FitImage)
@@ -439,7 +448,8 @@ define Device/edgecore_oap100
DEVICE_DTS_CONFIG := config@ap.dk07.1-c1
DEVICE_PACKAGES := ipq-wifi-edgecore_oap100 kmod-usb-acm kmod-usb-net kmod-usb-net-cdc-qmi uqmi
endef
-TARGET_DEVICES += edgecore_oap100
+# Missing DSA Setup
+#TARGET_DEVICES += edgecore_oap100
define Device/engenius_eap1300
$(call Device/FitImage)
@@ -452,7 +462,8 @@ define Device/engenius_eap1300
IMAGE_SIZE := 25344k
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
endef
-TARGET_DEVICES += engenius_eap1300
+# Missing DSA Setup
+#TARGET_DEVICES += engenius_eap1300
define Device/engenius_eap2200
$(call Device/FitImage)
@@ -464,7 +475,8 @@ define Device/engenius_eap2200
PAGESIZE := 2048
DEVICE_PACKAGES := ath10k-firmware-qca9888-ct -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
endef
-TARGET_DEVICES += engenius_eap2200
+# Missing DSA Setup
+#TARGET_DEVICES += engenius_eap2200
define Device/engenius_emd1
$(call Device/FitImage)
@@ -477,7 +489,8 @@ define Device/engenius_emd1
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
endef
-TARGET_DEVICES += engenius_emd1
+# Missing DSA Setup
+#TARGET_DEVICES += engenius_emd1
define Device/engenius_emr3500
$(call Device/FitImage)
@@ -492,7 +505,8 @@ define Device/engenius_emr3500
IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
DEFAULT := n
endef
-TARGET_DEVICES += engenius_emr3500
+# Missing DSA Setup
+#TARGET_DEVICES += engenius_emr3500
define Device/engenius_ens620ext
$(call Device/FitImage)
@@ -518,7 +532,8 @@ define Device/engenius_ens620ext
IMAGE/factory_30.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size | SenaoFW $$$$(PRODUCT_ID) $$$$(FW_VER)
IMAGE/factory_35.bin := qsdk-ipq-factory-nor | check-size | SenaoFW $$$$(PRODUCT_ID_NEW) $$$$(FW_VER_NEW)
endef
-TARGET_DEVICES += engenius_ens620ext
+# Missing DSA Setup
+#TARGET_DEVICES += engenius_ens620ext
define Device/extreme-networks_ws-ap3915i
$(call Device/FitImage)
@@ -530,7 +545,8 @@ define Device/extreme-networks_ws-ap3915i
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
DEVICE_PACKAGES := ipq-wifi-extreme-networks_ws-ap3915i
endef
-TARGET_DEVICES += extreme-networks_ws-ap3915i
+# Missing DSA Setup
+#TARGET_DEVICES += extreme-networks_ws-ap3915i
define Device/ezviz_cs-w3-wd1200g-eup
$(call Device/FitImage)
@@ -547,7 +563,8 @@ define Device/ezviz_cs-w3-wd1200g-eup
DEVICE_COMPAT_MESSAGE := uboot's bootcmd has to be updated (see wiki). \
Upgrade via sysupgrade mechanism is not possible.
endef
-TARGET_DEVICES += ezviz_cs-w3-wd1200g-eup
+# Missing DSA Setup
+#TARGET_DEVICES += ezviz_cs-w3-wd1200g-eup
define Device/glinet_gl-ap1300
$(call Device/FitImage)
@@ -562,7 +579,8 @@ define Device/glinet_gl-ap1300
KERNEL_INSTALL := 1
DEVICE_PACKAGES := ipq-wifi-glinet_gl-ap1300 kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
endef
-TARGET_DEVICES += glinet_gl-ap1300
+# Missing DSA Setup
+#TARGET_DEVICES += glinet_gl-ap1300
define Device/glinet_gl-b1300
$(call Device/FitzImage)
@@ -605,7 +623,8 @@ define Device/glinet_gl-s1300
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
DEVICE_PACKAGES := ipq-wifi-glinet_gl-s1300 kmod-fs-ext4 kmod-mmc kmod-spi-dev
endef
-TARGET_DEVICES += glinet_gl-s1300
+# Missing DSA Setup
+#TARGET_DEVICES += glinet_gl-s1300
define Device/linksys_ea6350v3
# The Linksys EA6350v3 has a uboot bootloader that does not
@@ -695,7 +714,8 @@ define Device/linksys_whw01-v1
check-size
DEVICE_PACKAGES := uboot-envtools kmod-leds-pca963x
endef
-TARGET_DEVICES += linksys_whw01-v1
+# Missing DSA Setup
+#TARGET_DEVICES += linksys_whw01-v1
define Device/luma_wrtq-329acn
$(call Device/FitImage)
@@ -707,7 +727,8 @@ define Device/luma_wrtq-329acn
BLOCKSIZE := 128k
PAGESIZE := 2048
endef
-TARGET_DEVICES += luma_wrtq-329acn
+# Missing DSA Setup
+#TARGET_DEVICES += luma_wrtq-329acn
define Device/meraki_mr33
$(call Device/FitImage)
@@ -742,7 +763,8 @@ define Device/mobipromo_cm520-79f
PAGESIZE := 2048
DEVICE_PACKAGES := kmod-usb-ledtrig-usbport
endef
-TARGET_DEVICES += mobipromo_cm520-79f
+# Missing DSA Setup
+#TARGET_DEVICES += mobipromo_cm520-79f
define Device/netgear_ex61x0v2
$(call Device/DniImage)
@@ -759,14 +781,16 @@ define Device/netgear_ex6100v2
DEVICE_MODEL := EX6100
DEVICE_VARIANT := v2
endef
-TARGET_DEVICES += netgear_ex6100v2
+# Missing DSA Setup
+#TARGET_DEVICES += netgear_ex6100v2
define Device/netgear_ex6150v2
$(call Device/netgear_ex61x0v2)
DEVICE_MODEL := EX6150
DEVICE_VARIANT := v2
endef
-TARGET_DEVICES += netgear_ex6150v2
+# Missing DSA Setup
+#TARGET_DEVICES += netgear_ex6150v2
define Device/netgear_orbi
$(call Device/DniImage)
@@ -794,7 +818,8 @@ define Device/netgear_rbr50
DEVICE_VARIANT := v1
NETGEAR_BOARD_ID := RBR50
endef
-TARGET_DEVICES += netgear_rbr50
+# Missing DSA Setup
+#TARGET_DEVICES += netgear_rbr50
define Device/netgear_rbs50
$(call Device/netgear_rbx50)
@@ -802,7 +827,8 @@ define Device/netgear_rbs50
DEVICE_VARIANT := v1
NETGEAR_BOARD_ID := RBS50
endef
-TARGET_DEVICES += netgear_rbs50
+# Missing DSA Setup
+#TARGET_DEVICES += netgear_rbs50
define Device/netgear_srx60
$(call Device/netgear_orbi)
@@ -817,14 +843,16 @@ define Device/netgear_srr60
DEVICE_MODEL := SRR60
NETGEAR_BOARD_ID := SRR60
endef
-TARGET_DEVICES += netgear_srr60
+# Missing DSA Setup
+#TARGET_DEVICES += netgear_srr60
define Device/netgear_srs60
$(call Device/netgear_srx60)
DEVICE_MODEL := SRS60
NETGEAR_BOARD_ID := SRS60
endef
-TARGET_DEVICES += netgear_srs60
+# Missing DSA Setup
+#TARGET_DEVICES += netgear_srs60
define Device/netgear_wac510
$(call Device/FitImage)
@@ -854,7 +882,8 @@ define Device/openmesh_a42
IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=A42
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
endef
-TARGET_DEVICES += openmesh_a42
+# Missing DSA Setup
+#TARGET_DEVICES += openmesh_a42
define Device/openmesh_a62
$(call Device/FitImageLzma)
@@ -870,7 +899,8 @@ define Device/openmesh_a62
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
DEVICE_PACKAGES := ath10k-firmware-qca9888-ct
endef
-TARGET_DEVICES += openmesh_a62
+# Missing DSA Setup
+#TARGET_DEVICES += openmesh_a62
define Device/p2w_r619ac
$(call Device/FitzImage)
@@ -909,7 +939,8 @@ define Device/pakedge_wr-1
IMAGE_SIZE := 31232k
IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata
endef
-TARGET_DEVICES += pakedge_wr-1
+# Missing DSA Setup
+#TARGET_DEVICES += pakedge_wr-1
define Device/plasmacloud_pa1200
$(call Device/FitImageLzma)
@@ -924,7 +955,8 @@ define Device/plasmacloud_pa1200
IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=PA1200
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
endef
-TARGET_DEVICES += plasmacloud_pa1200
+# Missing DSA Setup
+#TARGET_DEVICES += plasmacloud_pa1200
define Device/plasmacloud_pa2200
$(call Device/FitImageLzma)
@@ -940,7 +972,8 @@ define Device/plasmacloud_pa2200
IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
DEVICE_PACKAGES := ath10k-firmware-qca9888-ct
endef
-TARGET_DEVICES += plasmacloud_pa2200
+# Missing DSA Setup
+#TARGET_DEVICES += plasmacloud_pa2200
define Device/qcom_ap-dk01.1-c1
DEVICE_VENDOR := Qualcomm Atheros
@@ -988,7 +1021,8 @@ define Device/qxwlan_e2600ac-c1
DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac-c1
DEFAULT := n
endef
-TARGET_DEVICES += qxwlan_e2600ac-c1
+# Missing DSA Setup
+#TARGET_DEVICES += qxwlan_e2600ac-c1
define Device/qxwlan_e2600ac-c2
$(call Device/FitImage)
@@ -1002,7 +1036,8 @@ define Device/qxwlan_e2600ac-c2
PAGESIZE := 2048
DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac-c2
endef
-TARGET_DEVICES += qxwlan_e2600ac-c2
+# Missing DSA Setup
+#TARGET_DEVICES += qxwlan_e2600ac-c2
define Device/sony_ncp-hg100-cellular
$(call Device/FitImage)
@@ -1015,7 +1050,8 @@ define Device/sony_ncp-hg100-cellular
DEVICE_PACKAGES := e2fsprogs ipq-wifi-sony_ncp-hg100-cellular \
kmod-fs-ext4 uqmi
endef
-TARGET_DEVICES += sony_ncp-hg100-cellular
+# Missing DSA Setup
+#TARGET_DEVICES += sony_ncp-hg100-cellular
define Device/teltonika_rutx10
$(call Device/FitImage)
@@ -1031,7 +1067,8 @@ define Device/teltonika_rutx10
IMAGE/nand-factory.ubi := append-ubi | qsdk-ipq-factory-nand | append-rutx-metadata
DEVICE_PACKAGES := ipq-wifi-teltonika_rutx kmod-bluetooth
endef
-TARGET_DEVICES += teltonika_rutx10
+# Missing DSA Setup
+#TARGET_DEVICES += teltonika_rutx10
define Device/tel_x1pro
$(call Device/FitImage)
@@ -1044,7 +1081,8 @@ define Device/tel_x1pro
DEVICE_PACKAGES := kmod-usb-net-qmi-wwan kmod-usb-serial-option uqmi
DEFAULT := n
endef
-TARGET_DEVICES += tel_x1pro
+# Missing DSA Setup
+#TARGET_DEVICES += tel_x1pro
define Device/unielec_u4019-32m
$(call Device/FitImage)
@@ -1058,7 +1096,8 @@ define Device/unielec_u4019-32m
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
DEFAULT := n
endef
-TARGET_DEVICES += unielec_u4019-32m
+# Missing DSA Setup
+#TARGET_DEVICES += unielec_u4019-32m
define Device/zte_mf28x_common
$(call Device/FitzImage)
@@ -1082,7 +1121,8 @@ define Device/zte_mf289f
DEVICE_MODEL := MF289F
DEVICE_PACKAGES += ipq-wifi-zte_mf289f ath10k-firmware-qca9984-ct
endef
-TARGET_DEVICES += zte_mf289f
+# Missing DSA Setup
+#TARGET_DEVICES += zte_mf289f
define Device/zyxel_nbg6617
$(call Device/FitImageLzma)
@@ -1116,4 +1156,5 @@ define Device/zyxel_wre6606
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
endef
-TARGET_DEVICES += zyxel_wre6606
+# Missing DSA Setup
+#TARGET_DEVICES += zyxel_wre6606
diff --git a/target/linux/ipq40xx/image/mikrotik.mk b/target/linux/ipq40xx/image/mikrotik.mk
index d1f0829cd3..8491ff4a42 100644
--- a/target/linux/ipq40xx/image/mikrotik.mk
+++ b/target/linux/ipq40xx/image/mikrotik.mk
@@ -69,4 +69,5 @@ define Device/mikrotik_wap-ac
SOC := qcom-ipq4018
DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
endef
-TARGET_DEVICES += mikrotik_wap-ac
+# Missing DSA Setup
+#TARGET_DEVICES += mikrotik_wap-ac