aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2019-08-09 07:37:51 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2019-08-09 10:21:17 +0200
commitd8c62c40297feabb6bfd2c091588070a2e3fc11c (patch)
treee126e05b2857f25663433a2dabbeb814bfbfcad2 /target
parentabbbecaa73dcb5a36932a224f74488d0c5e3b3cd (diff)
downloadupstream-d8c62c40297feabb6bfd2c091588070a2e3fc11c.tar.gz
upstream-d8c62c40297feabb6bfd2c091588070a2e3fc11c.tar.bz2
upstream-d8c62c40297feabb6bfd2c091588070a2e3fc11c.zip
brcm2708: bcm2711: remove unneeded boot file
bootcode.bin isn't needed for RPi 4B since it's stored on a SPI-attached EEPROM. More info: https://www.raspberrypi.org/documentation/hardware/raspberrypi/booteeprom.md Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm2708/image/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index a9afa4e915..f1a4bb8dc4 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -25,7 +25,6 @@ define Build/boot-common
rm -f $@.boot
mkfs.fat -C $@.boot $(FAT32_BLOCKS)
mcopy -i $@.boot $(KDIR)/COPYING.linux ::
- mcopy -i $@.boot $(KDIR)/bootcode.bin ::
mcopy -i $@.boot $(KDIR)/LICENCE.broadcom ::
mcopy -i $@.boot cmdline.txt ::
mcopy -i $@.boot $(BOOT_CONFIG) ::config.txt
@@ -37,6 +36,7 @@ define Build/boot-common
endef
define Build/boot-2708
+ mcopy -i $@.boot $(KDIR)/bootcode.bin ::
mcopy -i $@.boot $(KDIR)/start.elf ::
mcopy -i $@.boot $(KDIR)/start_cd.elf ::
mcopy -i $@.boot $(KDIR)/start_x.elf ::
@@ -131,7 +131,6 @@ endif
define Device/rpi-4
DEVICE_MODEL := 4B
KERNEL_IMG := kernel8.img
- DEVICE_TITLE := Raspberry Pi 4B
DEVICE_DTS := broadcom/bcm2711-rpi-4-b
SUPPORTED_DEVICES := \
raspberrypi,4-model-b