aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-01-04 21:13:57 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-01-04 21:13:57 +0000
commitd65c6fe720c33dd05bd609d0c8570e3b4103d561 (patch)
treeaf37057fe846d1394e3672d214d4422fa3a45bdf /target
parentb8f0d861152439b4f8c6304c4f556cfd5317ee77 (diff)
downloadupstream-d65c6fe720c33dd05bd609d0c8570e3b4103d561.tar.gz
upstream-d65c6fe720c33dd05bd609d0c8570e3b4103d561.tar.bz2
upstream-d65c6fe720c33dd05bd609d0c8570e3b4103d561.zip
ar71xx: create profile and build image for the ALFA AP96 board
SVN-Revision: 29663
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/alfa.mk12
-rw-r--r--target/linux/ar71xx/image/Makefile6
2 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/alfa.mk b/target/linux/ar71xx/generic/profiles/alfa.mk
index 8c09e606c5..06baf240c2 100644
--- a/target/linux/ar71xx/generic/profiles/alfa.mk
+++ b/target/linux/ar71xx/generic/profiles/alfa.mk
@@ -5,6 +5,18 @@
# See /LICENSE for more information.
#
+define Profile/ALFAAP96
+ NAME:=ALFA Network AP96 board
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-rtc-pcf2123
+endef
+
+define Profile/ALFAAP96/Description
+ Package set optimized for the ALFA Network AP96 board.
+endef
+
+$(eval $(call Profile,ALFAAP96))
+
+
define Profile/HORNETUB
NAME:=ALFA Network Hornet-UB board
PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 4e143ddc0e..47a0b04e8a 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -588,6 +588,12 @@ define Image/Build/Profile/ALFANX
$(call Image/Build/Template/$(fs_64k)/$(1),ALFA,alfa-nx,$(alfa_nx_cmdline),1638400,6291456,vmlinux.gz.uImage,pb9x-2.6.31-jffs2)
endef
+alfa_ap96_cmdline=board=ALFA-AP96 console=ttyS0,115200
+alfa_ap96_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,256k(u-boot-env)ro,13312k(rootfs),2048k(kernel),512k(caldata)ro,15360k@0x80000(firmware)
+define Image/Build/Profile/ALFAAP96
+ $(call Image/Build/Template/$(fs_128k)/$(1),AthLzma,alfa-ap96,$(alfa_ap96_cmdline),alfa_ap96_mtdlayout,2097152,13631488,RK)
+endef
+
ap121_mtdlayout_2M=mtdparts=spi0.0:64k(u-boot)ro,1216k(rootfs),704k(kernel),64k(art)ro,1920k@0x10000(firmware)
ap121_mtdlayout_4M=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,2752k(rootfs),896k(kernel),64k(nvram),64k(art)ro,3648k@0x50000(firmware)